Package Details: gtk-theme-elementary 5.0-1

Git Clone URL: https://aur.archlinux.org/gtk-theme-elementary.git (read-only)
Package Base: gtk-theme-elementary
Description: The official elementary GTK theme designed to be smooth, attractive, fast, and usable.
Upstream URL: https://launchpad.net/egtk
Keywords: elementary gtk theme
Licenses: GPL2
Groups: pantheon
Conflicts: egtk-bzr, elementary-gtk-theme
Submitter: Ner0
Maintainer: goetzc
Last Packager: goetzc
Votes: 292
Popularity: 1.617140
First Submitted: 2013-08-30 09:50
Last Updated: 2016-08-16 23:09

Dependencies (2)

Required by (0)

Sources (1)

Latest Comments

josemota commented on 2015-08-14 09:27

To be consistent with naming, this one package should be kept, IMO.

Kycok commented on 2015-08-13 20:27

Hehe, that's the same theme. Think my package can be removed or merged

eolianoe commented on 2015-08-13 16:31

What is the difference between your package and gtk-theme-elementary [1] ?

[1] https://aur.archlinux.org/packages/gtk-theme-elementary/

Kycok commented on 2015-07-22 12:27

Thanks a lot, TrialnError. I've removed unico engine from dependencies + now murrine engine is optional

TrialnError commented on 2015-07-22 11:41

Note that gtk-engine-unico was dropped from the Repos (and apparantly not to the AUR).
Is it even still required? Running grep on it doesn't find a reference (whereas murrine is found).
Additionally if this is a gtk2/3 theme, the gtk-engine-murrine could be an optdeps, since it's just required for the gtk2 theme, and people just using gtk3 apps won't need this

feskyde commented on 2015-05-10 03:47

Updated to 4.0-3

- Fixes

Federico Damián

feskyde commented on 2015-05-10 03:44

Updated to 4.0-2:

- Now provides 'gtk-theme-elementary-bzr' (old version)

Federico Damián

alucryd commented on 2013-08-30 17:05

Thx, merging into gtk-theme-elementary.

Ner0 commented on 2013-08-30 09:50

Done.

alucryd commented on 2013-08-29 13:17

Ner0: For consistency too, could you upload this as gtk-theme-elementary? I'll do the merge afterwards.

Ner0 commented on 2013-08-04 04:22

The theme isn't compatible with GNOME 3.8.

beitme commented on 2013-08-04 04:04

checkboxes don't show whether they're marked or not. this happens with transmission and gedit. can't find any solution so i'm forced to remove my vote.

mus commented on 2012-10-27 19:27

I'm using [testing] and all gtk3 based applications segfault when using this theme. can anyone confirm this?

Anonymous comment on 2012-05-23 19:18

@Ner0 I had to set 'Minimize' function on middle click with Gnome Tweak Tool. Thanks anyway

hobarrera commented on 2012-05-23 17:27

What are you talking about? Are you using emerald, or something like that? I didn't know this theme included window-decorator themes as well.

Ner0 commented on 2012-05-23 17:22

They've dropped the minimize button - http://elementaryos.org/journal/whats-window-controls

Try minimizing with the middle click.

Anonymous comment on 2012-05-23 17:07

the 'minimize' button is missing, other themes (like adwaita cupertino) have it

CaioAlonso commented on 2012-05-01 14:03

@tuldok89 same here

Anonymous comment on 2012-05-01 09:33

Hello there guys. I had a bit of a problem with this theme. After installing and activating it, there are no transparency effects.

Screenshot -> http://i.imgur.com/2j97O.png

In this screenshot, you'll see that the inside of the selection box is opaque.

hobarrera commented on 2012-04-27 03:27

"marlin-bzr" is in no way an optional dependency; it's just something from the same developers.

Ner0 commented on 2012-04-04 14:01

This theme is compatible with gtk3 3.4, which is in the [gnome-unstable] repo.

https://bbs.archlinux.org/viewtopic.php?id=137444

Ner0 commented on 2012-04-03 19:39

You need to enable [gnome-unstable] repo in order to this theme display properly.

https://bbs.archlinux.org/viewtopic.php?id=137444

Ner0 commented on 2012-04-03 13:04

Updated, but the theme doesn't look good, atleast for me.
I guess it's made for gtk3 3.4.

Anonymous comment on 2012-04-03 08:50

http://elementaryos.org/journal/elementary-gtk-theme-version-30-released

Ner0 commented on 2012-03-07 12:20

It's been a year since the last stable version was released.
Maybe we should pick the most stable bzr revision and bump the version to 3.0_alpha or something.

Ner0 commented on 2012-03-06 13:48

This theme is updated once every six months.
Maybe we should pick the most stable bzr revision and bump the version to 3.0_alpha or something.

Ner0 commented on 2012-03-06 13:30

This theme is updated once in six months.
Maybe we should pick the most stable bzr revision and bump the version to 3.0_alpha or something.

davidovitch commented on 2012-03-05 22:19

en_US too, I use a Belgian keyboard but that shouldn't have any influence I guess? After some searching I've noticed a similar error happening here: http://aur.archlinux.org/packages.php?ID=47589

dserban commented on 2012-03-05 17:47

@davidovitch, what locale do you have?
I have en_US and the last time I tried building the package, it worked for me.

davidovitch commented on 2012-03-05 17:32

Building fails for the same reason as mentioned below. It seems that egtk/gtk-3.0, which seem to be just simlinks to egtk/gtk-2.0, refuse to get extracted from the archive for some reason (I don't know why).

leafonsword commented on 2012-02-08 13:21

..................................
egtk/gtk-3.0/nautilus/button/breadcrumb_normal.png: Cannot extract through symlink egtk/gtk-3.0
egtk/gtk-3.0/nautilus/button/left_slider_normal_alt.png: Cannot extract through symlink egtk/gtk-3.0
egtk/gtk-3.0/nautilus/button/breadcrumb_prelight.png: Cannot extract through symlink egtk/gtk-3.0
egtk/gtk-3.0/nautilus/button/right_slider_normal_alt.png: Cannot extract through symlink egtk/gtk-3.0
egtk/gtk-3.0/Apps/midori/base.png: Cannot extract through symlink egtk/gtk-3.0
bsdtar: Error exit delayed from previous errors.
==> 错误: 无法解压缩 egtk.zip
正在放弃...
==> ERROR: Makepkg was unable to build elementary-gtk-theme.

leafonsword commented on 2012-02-08 13:21

egtk/gtk-3.0/Button/normal.png: Cannot extract through symlink egtk/gtk-3.0
egtk/gtk-3.0/Button/mode_normal.png: Cannot extract through symlink egtk/gtk-3.0
egtk/gtk-3.0/Button/mode_pressed.png: Cannot extract through symlink egtk/gtk-3.0
egtk/gtk-3.0/Button/mode_prelight.png: Cannot extract through symlink egtk/gtk-3.0
egtk/gtk-3.0/Button/insensitive.png: Cannot extract through symlink egtk/gtk-3.0
egtk/gtk-3.0/Button/selected.png: Cannot extract through symlink egtk/gtk-3.0
egtk/gtk-3.0/Apps/panel-dark.rc: Cannot extract through symlink egtk/gtk-3.0
egtk/gtk-3.0/Apps/panel.rc: Cannot extract through symlink egtk/gtk-3.0
egtk/gtk-3.0/Apps/postler.rc.~1~: Cannot extract through symlink egtk/gtk-3.0
egtk/gtk-3.0/Apps/panel.rc.~1~: Cannot extract through symlink egtk/gtk-3.0
egtk/gtk-3.0/Apps/steadyflow.rc: Cannot extract through symlink egtk/gtk-3.0
egtk/gtk-3.0/Apps/totem.rc: Cannot extract through symlink egtk/gtk-3.0
egtk/gtk-3.0/Apps/gedit.rc: Cannot extract through symlink egtk/gtk-3.0
egtk/gtk-3.0/Apps/eog.rc: Cannot extract through symlink egtk/gtk-3.0
egtk/gtk-3.0/Apps/panel-dark.rc.~1~: Cannot extract through symlink egtk/gtk-3.0
egtk/gtk-3.0/Apps/gnome-terminal.rc: Cannot extract through symlink egtk/gtk-3.0
egtk/gtk-3.0/Apps/nautilus.rc: Cannot extract through symlink egtk/gtk-3.0
egtk/gtk-3.0/Apps/dexter.rc: Cannot extract through symlink egtk/gtk-3.0
egtk/gtk-3.0/Apps/postler.rc: Cannot extract through symlink egtk/gtk-3.0
egtk/gtk-3.0/Apps/midori.rc: Cannot extract through symlink egtk/gtk-3.0
egtk/gtk-3.0/nautilus/old/right_slider_normal.png: Cannot extract through symlink egtk/gtk-3.0
egtk/gtk-3.0/nautilus/old/left_slider_normal.png: Cannot extract through symlink egtk/gtk-3.0
egtk/gtk-3.0/nautilus/old/breadcrumb_normal.png: Cannot extract through symlink egtk/gtk-3.0
egtk/gtk-3.0/nautilus/old/breadcrumb_prelight.png: Cannot extract through symlink egtk/gtk-3.0
egtk/gtk-3.0/nautilus/button/breadcrumb_normal.png: Cannot extract through symlink egtk/gtk-3.0
egtk/gtk-3.0/nautilus/button/left_slider_normal_alt.png: Cannot extract through symlink egtk/gtk-3.0
egtk/gtk-3.0/nautilus/button/breadcrumb_prelight.png: Cannot extract through symlink egtk/gtk-3.0
egtk/gtk-3.0/nautilus/button/right_slider_normal_alt.png: Cannot extract through symlink egtk/gtk-3.0
egtk/gtk-3.0/Apps/midori/base.png: Cannot extract through symlink egtk/gtk-3.0
bsdtar: Error exit delayed from previous errors.
==> 错误: 无法解压缩 egtk.zip
正在放弃...
==> ERROR: Makepkg was unable to build elementary-gtk-theme.

Casper commented on 2012-02-07 08:25

egtk/gtk-3.0/nautilus/button/breadcrumb_prelight.png: Cannot extract through symlink egtk/gtk-3.0
egtk/gtk-3.0/nautilus/button/right_slider_normal_alt.png: Cannot extract through symlink egtk/gtk-3.0
egtk/gtk-3.0/Apps/midori/base.png: Cannot extract through symlink egtk/gtk-3.0
bsdtar: Error exit delayed from previous errors.
==> ОШИБКА: Не удалось распаковать egtk.zip
Преждевременный выход...
==> ERROR: Makepkg was unable to build elementary-gtk-theme.
==> Restart building elementary-gtk-theme ? [y/N]
==> ---------------------------------------------
==>

Casper commented on 2012-02-07 08:18

egtk/gtk-3.0/nautilus/button/breadcrumb_prelight.png: Cannot extract through symlink egtk/gtk-3.0
egtk/gtk-3.0/nautilus/button/right_slider_normal_alt.png: Cannot extract through symlink egtk/gtk-3.0
egtk/gtk-3.0/Apps/midori/base.png: Cannot extract through symlink egtk/gtk-3.0
bsdtar: Error exit delayed from previous errors.
==> ОШИБКА: Не удалось распаковать egtk.zip
Преждевременный выход...
==> ERROR: Makepkg was unable to build elementary-gtk-theme.
==> Restart building elementary-gtk-theme ? [y/N]
==> ---------------------------------------------
==>

francoism commented on 2012-02-01 11:29

Does it works fine with gtk3? Smooth borders? Or is it just me..?

paterbrown commented on 2011-06-27 11:24

I'm no longer interested at this package. Feel free to adopt...

paterbrown commented on 2011-04-07 06:29

@Madek: This seems to be a bug. DanRabbit has GTK3-things changed in BZR. We should wait for the new version.

Madek commented on 2011-04-07 01:05

the theme don't work in gtk3 apps, in gtk2 works fine

paterbrown commented on 2011-03-07 09:18

For user who prefer the light panel: change <code>include "Apps/panel-dark.rc"</code> to <code>include "Apps/panel.rc"</code> in /usr/share/themes/elementary/gtk-2.0/gtkrc

paterbrown commented on 2011-03-06 11:33

I'm unhappy with the new version v2.1 (especially the new dark panel). So i wrote the package elementary-gtk-theme-2.0 (https://aur.archlinux.org/packages.php?ID=47144) with the old theme v2.0.

paterbrown commented on 2011-01-09 12:23

@caspian: For the new breadcrumbs you need nautilus-elementary-bzr. Then you will find an option in Nautilus.

caspian commented on 2010-11-09 09:02

Is anyone having problems with new breadcrumbs style not showing after installation of newest version?? My breadcrumb style is the same like in the previous version. I've checked everything and can't find what is causing this.

paterbrown commented on 2010-10-31 12:55

Hi dundee, two notes:
- Equinox engine ist kicked since 2.0
- in optdepends you should change nautilus-elementary to nautilus-elementary-bzr

caspian commented on 2010-10-27 19:27

Why don't you update the pkgbuild now? There is elementary-theme 2.0.1~ppa183 on PPA since 25/10...

Anonymous comment on 2010-10-19 14:38

I see, I've read the new 2.x packages were uploaded, see http://launchpad.net/egtk. But maybe I'm a bit too early, sorry about that

dundee commented on 2010-10-19 11:47

3cHeLoN:
Tha package is up to data. See http://ppa.launchpad.net/elementaryart/ppa/ubuntu/dists/maverick/main/binary-i386/Packages

sancospi commented on 2010-09-29 04:44

sha256sums is wrong, the correct sha256sum is = 1fea28bb08e89c63bdcb9ba8ee612b4e8fd9bea56a715efe6d7d8bcd7848013f

Anonymous comment on 2010-08-06 11:12

yea i would be interested to take over this one

paterbrown commented on 2010-07-20 13:44

I have changed the OS. Somebody interested to adopt this package? Btw, the elementary-icons are also orphaned.

paterbrown commented on 2010-06-11 17:35

Upgrade to v1.2.1, but be aware the improvements are made for nautilus elementary. The vanilla nautilus looks ugly (see also: http://raschix.de/neue-version-des-elementary-theme-fuer-gnome). The old PKGBUILD can you find at http://github.com/raschix/pkgbuilds