Package Details: gtk2-dfb 2.24.31-1

Git Clone URL: (read-only)
Package Base: gtk2-dfb
Description: directfb backend for GTK+
Upstream URL:
Licenses: LGPL
Submitter: bountykiller
Maintainer: lks
Last Packager: lks
Votes: 10
Popularity: 0.000000
First Submitted: 2007-06-04 21:32
Last Updated: 2016-10-01 12:24

Latest Comments

lks commented on 2014-06-27 22:04

Update: Now the 'gtk2-dfb: requires gtk2=2.24.21' issue is fixed. However, those who update versions prior 2.24.24 have still to deal with that stuff.

All is solved by turning 'depends=("gtk2=$pkgver")' into 'depends=("gtk2>=$pkgver")'. This is indeed wrong because gtk2-dfb depends on the equal version of gtk2 but changing that gives you the enhance of doing a proper update with 'yaourt' or whatever.

lks commented on 2013-10-12 16:15

I am sorry. There was an update in gtk2. To update you have to use 'pacman -Sdu' if 'pacman -Su' failed with:

'error: failed to prepare transaction (could not satisfy dependencies)
:: gtk2-dfb: requires gtk2=2.24.21'

Finaly, update gtk2-dfb.

lks commented on 2013-10-12 14:20

I forgot to mention that you have to rebuild gtk2-packages in order to use this package. It would be nice if someone could submit at least one well-working example app!

lks commented on 2013-10-12 13:57

Notes to the current version:
Like cairo-dfb it has moved from /opt/gtkdfb to /usr. It does no longer depend on pango-dfb.
The gtk2-dfb has only the directfb-backend and is therefore much much smaller. However I don't know how to build just the backend (so it builds all).

viniavila commented on 2012-08-30 19:29

Did you compile it to support framebuffer? How did you do it?

Maribu commented on 2012-08-29 16:54

Hey, viniavila!

Version 24.11 worked fine for me (an Arch Linux ARM). Give it a try!


viniavila commented on 2012-04-30 21:10

That's more difficult compile this than I expected ¬¬'

GTK dependencies is too old... I'm trying compile from last version on 2.x series (2.24), but without sucessful yet.

Any help will be good!.



Anonymous comment on 2012-01-12 15:39

Missing dependencies (or the configure line needs changing): libtiff, jasper

jichu4n commented on 2011-11-23 08:39