Package Details: gtk2-ubuntu 2.24.32-1

Git Clone URL: https://aur.archlinux.org/gtk2-ubuntu.git (read-only)
Package Base: gtk2-ubuntu
Description: GObject-based multi-platform GUI toolkit (legacy)
Upstream URL: http://www.gtk.org/
Licenses: LGPL
Conflicts: gtk2
Provides: gtk2=2.24.32
Submitter: horsemanoffaith
Maintainer: horsemanoffaith
Last Packager: horsemanoffaith
Votes: 2
Popularity: 0.000031
First Submitted: 2015-12-31 22:35
Last Updated: 2018-05-05 03:32

Required by (1000)

Sources (5)

Latest Comments

quequotion commented on 2019-10-08 14:22

This one needs automake-1.15 and git in makedepends():

diff --git a/PKGBUILD b/PKGBUILD
index ff23b98..03ef0a6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -18,7 +18,7 @@ url="http://www.gtk.org/"
 license=(LGPL)
 depends=(atk cairo desktop-file-utils gtk-update-icon-cache libcups librsvg libxcomposite 
          libxcursor libxdamage libxi libxinerama libxrandr pango shared-mime-info)
-makedepends=(gobject-introspection gtk-doc python2)
+makedepends=(automake-1.15 git gobject-introspection gtk-doc python2)
 optdepends=('adwaita-icon-theme: Default icon theme'
            'gnome-themes-standard: Default widget theme')
 provides=("gtk2=${pkgver}")

Note: automake in [core] is up to version 1.16; gtk2(-ubuntu) is too old for it. (Un)fortunately automake-1.15 is only available in the AUR.

To clean chroot build, build automake-1.15 first, then preinstall it:

makechrootpkg -c -r $CHROOT -I ../automake-1.15/automake-1.15-1.15.1-2-any.pkg.tar.xz

horsemanoffaith commented on 2018-05-27 21:59

@sergey.orloff- I'm not sure where your error is coming from. Is your system updated?

sergey.orloff commented on 2018-05-12 23:36

ERROR: xref linking to gtk-Stock-Items has no generated link text. Error: no ID for constraint linkend: "gtk-Stock-Items". ERROR: xref linking to XML-UI has no generated link text. Error: no ID for constraint linkend: "XML-UI". make[4]: [Makefile:1275: html-build.stamp] Ошибка 245 make[4]: выход из каталога «/build/gtk2-ubuntu/src/gtk/docs/reference/gtk» make[3]: [Makefile:502: all-recursive] Ошибка 1 make[3]: выход из каталога «/build/gtk2-ubuntu/src/gtk/docs/reference» make[2]: [Makefile:504: all-recursive] Ошибка 1 make[2]: выход из каталога «/build/gtk2-ubuntu/src/gtk/docs» make[1]: [Makefile:730: all-recursive] Ошибка 1 make[1]: выход из каталога «/build/gtk2-ubuntu/src/gtk» make: *** [Makefile:622: all] Ошибка 2 ==> ОШИБКА: Произошел сбой в build(). Прерывание...