Package Details: gtkam 1.0-2

Git Clone URL: https://aur.archlinux.org/gtkam.git (read-only)
Package Base: gtkam
Description: A GTK frontend for libgphoto2
Upstream URL: http://gphoto.sourceforge.net/proj/gtkam
Licenses: GPL
Submitter: ilpianista
Maintainer: bidulock
Last Packager: bidulock
Votes: 85
Popularity: 0.001686
First Submitted: 2010-11-13 15:01
Last Updated: 2017-11-19 05:07

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 Next › Last »

aaronp commented on 2011-12-28 23:55

You got it, that worked. :)

valr commented on 2011-12-28 23:14

Could you try now ? (second patch included)

aaronp commented on 2011-12-28 20:42

Build fails for me (i686).

/usr/bin/ld: libgtkam.a(libgtkam_a-gtkam-save.o): undefined reference to symbol 'gtk_adjustment_get_type'
/usr/bin/ld: note: 'gtk_adjustment_get_type' is defined in DSO /usr/lib/libgtk-x11-2.0.so.0 so try adding it to the linker command line
/usr/lib/libgtk-x11-2.0.so.0: could not read symbols: Invalid operation
collect2: ld returned 1 exit status
make[2]: *** [gtkam] Error 1
make[2]: Leaving directory `/tmp/clyde-aaron/gtkam/gtkam/src/gtkam-0.1.18/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/tmp/clyde-aaron/gtkam/gtkam/src/gtkam-0.1.18'
make: *** [all] Error 2

valr commented on 2011-12-22 09:10

Sorry for the delay.
It should work now (well, at least works for me with the patch).

Andyvec commented on 2011-12-20 22:19

Any progress?
I tried to make it work, but I could't deal with the dependecies

valr commented on 2011-12-16 10:33

Well, I don't remember having faced any problem during compilation, but it seems it's missing some libs then.
A quick look at the autotools show this error:

In configure.ac:

PKG_CHECK_MODULES([GTK], [gtk+-2.0])
AC_SUBST([GTK_CFLAGS])
AC_SUBST([GTK_LIBS])

In Makefile.am:

gtkam_LDADD = \
libgtkam.a \
$(LIBEXIF_LIBS) \
$(LIBEXIF_GTK_LIBS) \
$(LIBGPHOTO2_LIBS) \
$(GTKAM_LIBS) \ <- this should be GTK_LIBS
$(BONOBO_LIBS) \
$(GNOME_LIBS) \
$(INTLLIBS)

I'll patch it tonight when I'm back at home.

kritztopf commented on 2011-12-16 09:36

Is it just me or is this line missing in the PKGBUILD?

export LDFLAGS=" -lgtk-x11-2.0 -lgdk_pixbuf-2.0 -lgobject-2.0 -lglib-2.0"

Did not compile without it.

valr commented on 2011-10-30 11:00

Changelog 0.1.18: fixed translation issues for GIMP

valr commented on 2011-08-21 08:52

Intltool is required (and so perl-xml-parser) -> added in makedepends.
Thanks

Arhat commented on 2011-08-06 09:31

I've noticed extra/perl-xml-parser is required, but not pulled in automatically by makepkg -s