Package Details: gtkcord3 0.0.4-2

Git Clone URL: https://aur.archlinux.org/gtkcord3.git (read-only, click to copy)
Package Base: gtkcord3
Description: Discord client written in go and gtk3
Upstream URL: https://github.com/diamondburned/gtkcord3
Licenses: GPL3
Submitter: nik123true
Maintainer: nik123true
Last Packager: nik123true
Votes: 3
Popularity: 1.08
First Submitted: 2020-03-29 21:11
Last Updated: 2020-10-13 21:37

Latest Comments

keilmillerjr commented on 2020-10-15 11:54

@nik123tru

System:
  Kernel: 5.8.11-1-MANJARO x86_64 bits: 64 compiler: N/A 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.8-x86_64 
  root=UUID=8ddaa5e3-9f1d-4233-a023-29ea2cad9e44 rw quiet apparmor=1 
  security=apparmor udev.log_priority=3 
  Desktop: GNOME 3.36.6 tk: GTK 3.24.23 wm: gnome-shell dm: GDM 3.36.3 
  Distro: Manjaro Linux 

I already have the 0.0.4-1 aur package installed. It fails when trying to update to 0.0.4-2.

nik123true commented on 2020-10-14 21:32

@keilmillerjr What distro are you on? It seems that the package is for Arch only.

keilmillerjr commented on 2020-10-14 21:27

gtkcord3 0.0.4-2

Preparing...
Cloning gtkcord3 build files...
Checking gtkcord3 dependencies...
Synchronizing package databases...
Failed to prepare transaction:
could not satisfy dependencies:
- unable to satisfy dependency 'libhandy0' required by gtkcord3
Resolving dependencies...
Warning: cannot resolve "libhandy0", a dependency of "gtkcord3"
Failed to prepare transaction:
could not satisfy dependencies:
- unable to satisfy dependency 'libhandy0' required by gtkcord3
Transaction cancelled.

nik123true commented on 2020-10-13 21:38

@gizlu Thanks. I've taken care of that

gizlu commented on 2020-10-13 18:55

==> Starting build()...
go: downloading github.com/markbates/pkger v0.15.1
go: downloading github.com/pkg/errors v0.9.1
go: downloading github.com/gotk3/gotk3 v0.4.1-0.20200508185535-d1638cba009b
go: downloading github.com/diamondburned/arikawa v0.6.4
go: downloading github.com/diamondburned/ningen v0.0.0-20200515163503-6722e2cc2e59
go: downloading github.com/sasha-s/go-deadlock v0.2.0
go: downloading github.com/yuin/goldmark v1.1.30
go: downloading github.com/alecthomas/chroma v0.7.1
go: downloading github.com/zalando/go-keyring v0.0.0-20200121091418-667557018717
go: downloading github.com/skratchdot/open-golang v0.0.0-20200116055534-eef842397966
go: downloading github.com/disintegration/imaging v1.6.2
go: downloading github.com/petermattis/goid v0.0.0-20180202154549-b0b1615b78e5
go: downloading golang.org/x/time v0.0.0-20200416051211-89c76fbcd5d1
go: downloading github.com/gorilla/websocket v1.4.2
go: downloading github.com/goodsign/monday v1.0.0
go: downloading golang.org/x/sync v0.0.0-20200317015054-43a5402ce75a
go: downloading github.com/gorilla/schema v1.1.0
go: downloading github.com/dlclark/regexp2 v1.1.6
go: downloading github.com/gobuffalo/here v0.6.0
go: downloading github.com/danwakefield/fnmatch v0.0.0-20160403171240-cbb64ac3d964
go: downloading github.com/diamondburned/handy v0.0.0-20200415062301-8c5fb8c91329
go: downloading github.com/logrusorgru/aurora v0.0.0-20200102142835-e9ef32dff381
go: downloading github.com/Xuanwo/go-locale v0.1.0
go: downloading github.com/godbus/dbus v4.1.0+incompatible
go: downloading github.com/davecgh/go-spew v1.1.1
go: downloading golang.org/x/image v0.0.0-20191009234506-e7c1f5e7dbb8
go: downloading golang.org/x/text v0.3.2
# pkg-config --cflags  -- libhandy-0.0 gtk+-3.0
Package libhandy-0.0 was not found in the pkg-config search path.
Perhaps you should add the directory containing `libhandy-0.0.pc'
to the PKG_CONFIG_PATH environment variable
Package 'libhandy-0.0', required by 'virtual:world', not found
pkg-config: exit status 1

Builds normally after installation of libhandy0 package

nik123true commented on 2020-09-03 12:02

Not sure, will have to research, although I don't have as much time now since I'm attending online classes.

egils commented on 2020-09-03 09:47

When I try to install it just builds forever with no output. Is there some way of finding out what go is doing?

nik123true commented on 2020-06-19 15:57

@katt nevermind, I just figured out that I forgot to add conflicts in the -git package. My bad

nik123true commented on 2020-06-19 15:50

@katt while I did add the conflict field in the -git version of the package, I'm just not sure why when you try to install the non-git version it doesn't generate a conflict? Any way to fix this?

katt commented on 2020-06-19 15:43

You're supposed to reset the pkgrel on a a new pkgver, not increase it further. Also the -git package is the one who's supposed to conflict & provide the package, not the other way around.

Oh and it should depend on discordlogin and have that the -git package provide it.

And before I forget, please take a look at the updates go packaging guidelines: https://wiki.archlinux.org/index.php/Go_package_guidelines