Package Details: gtkparasite-git 0.3.0.r95.445cd7a-2

Git Clone URL: (read-only)
Package Base: gtkparasite-git
Description: GTK+ debugging and development tool for GTK+3 applications
Upstream URL:
Licenses: MIT
Submitter: None
Maintainer: Muflone
Last Packager: Muflone
Votes: 30
Popularity: 0.000002
First Submitted: 2009-01-21 19:52
Last Updated: 2015-06-13 16:05

Latest Comments

Muflone commented on 2014-09-06 12:16

Package updated and ported to GTK+ 3

Muflone commented on 2014-09-06 09:56

I adopted this package and I'll maintain it at the best I can.
Thank you luolimao for your work.

Muflone commented on 2014-07-27 15:19

The latest available GTK+ 2.0 version is the commit 0a0c90b
You can use the gtkparasite-gtk2 package

Muflone commented on 2014-07-27 10:34

Fail to build

which: no in (/usr/lib/ccache/bin:/usr/local/sbin:/usr/local/bin:/usr/bin:/opt/android-sdk/platform-tools:/opt/android-sdk/tools:/usr/bin/site_perl:/usr/bin/vendor_perl:/usr/bin/core_perl)
You need to install gnome-common

Adding gnome-common in makedepends the problem is solved

luolimao commented on 2014-07-24 09:17

The code itself has gtk3 specific code, so I don't think a gtk2 build is possible at the moment. Updated the dependencies to get the gtk3 version to build, at least.

avalak commented on 2014-04-02 10:15

Add "git checkout 0a0c90b" for gtk2 version.

avalak commented on 2014-04-02 10:13

@jo-shva, @baongoc124

Add <code>git checkout 0a0c90b</code> before
<code>echo $(awk -F , '/^AC_INIT/ {print $2}' | tr -d '[ ]').$(git rev-list --count HEAD).$(git rev-parse --short HEAD)</code>

jo-shva commented on 2014-04-02 07:59

This package doesn't build a Gtk2 version. It doesn't build a working version at all. It would be fantastic if you were able to get this package working for Gtk2.

baongoc124 commented on 2014-02-01 14:50

I cannot build this package for gtk2 anymore. It always spit out gtk3 modules. Does anyone know how to fix this? Thanks.

Muflone commented on 2014-01-19 20:49

Thank you oxez, added the gnome-common and gtksourceview3 dependencies.

All comments