Package Details: gtksourceview5 5.2.0-1

Git Clone URL: https://aur.archlinux.org/gtksourceview5.git (read-only, click to copy)
Package Base: gtksourceview5
Description: A text widget adding syntax highlighting and more to GNOME
Upstream URL: https://gitlab.gnome.org/GNOME/gtksourceview
Keywords: Adwaita Gnome GTK4
Licenses: LGPL
Submitter: flipflop97
Maintainer: flipflop97
Last Packager: flipflop97
Votes: 6
Popularity: 1.51
First Submitted: 2021-04-15 09:40
Last Updated: 2021-09-04 19:22

Latest Comments

apastuszak commented on 2021-09-03 16:26

Summary of Failures:

 8/22 test-buffer               FAIL            0.81s   killed by signal 5 SIGTRAP
14/22 test-printcompositor      FAIL            0.83s   killed by signal 5 SIGTRAP
16/22 test-space-drawer         FAIL            0.78s   killed by signal 5 SIGTRAP
21/22 test-view                 FAIL            0.58s   killed by signal 5 SIGTRAP


Ok:                 18  
Expected Fail:      0   
Fail:               4   
Unexpected Pass:    0   
Skipped:            0   
Timeout:            0 

flipflop97 commented on 2021-05-11 13:02

I'm not sure what causes this error yet, if anyone does, let me know!

In the meantime I've added the workaround that disables building gtk-doc.

simsilver commented on 2021-05-11 03:51

change gtk_doc to false works

diff --git a/PKGBUILD b/PKGBUILD
index dd8a1e8..72a6f80 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -19,7 +19,7 @@ source=("git+https://gitlab.gnome.org/GNOME/gtksourceview.git#tag=${pkgver}")
 sha256sums=('SKIP')

 build() {
-       arch-meson gtksourceview build -D gtk_doc=true
+       arch-meson gtksourceview build -D gtk_doc=false
        meson compile -C build
 }

mmoya commented on 2021-05-06 07:45

Build failed with

Building documentation for gtksourceview-5.0                                                                                                                                                                                                                                                
ERROR: Error in gtkdoc helper script:                                                                                                                                                                                                                                                       

ERROR: ['/usr/bin/gtkdoc-scangobj', '--types=/home/mmoya/.cache/yay/gtksourceview5/src/build/docs/reference/gtksourceview-5.0.types', '--module=gtksourceview-5.0', '--run=', '--cflags=-I@BUILD_ROOT@/. -I@SOURCE_ROOT@/. -I/usr/include/fribidi -I/usr/include/glib-2.0 -I/usr/lib/glib-2.
0/include -pthread -I/usr/include/libmount -I/usr/include/blkid -I/usr/include/gtk-4.0 -I/usr/include/pango-1.0 -I/usr/include/harfbuzz -I/usr/include/freetype2 -I/usr/include/libpng16 -I/usr/include/cairo -I/usr/include/lzo -I/usr/include/pixman-1 -I/usr/include/gdk-pixbuf-2.0 -I/us
r/include/graphene-1.0 -I/usr/lib/graphene-1.0/include -mfpmath=sse -msse -msse2 -I/usr/include/gio-unix-2.0 -I/usr/include/libxml2 -march=x86-64 -mtune=generic -O2 -pipe -fno-plt -fexceptions -Wp,-D_FORTIFY_SOURCE=2,-D_GLIBCXX_ASSERTIONS -Wformat -Werror=format-security -fstack-clas
h-protection -fcf-protection -DG_DISABLE_ASSERT -DG_DISABLE_CAST_CHECKS -DG_DISABLE_DEPRECATED -DGDK_DISABLE_DEPRECATED -DGTK_DISABLE_DEPRECATED -DGDK_PIXBUF_DISABLE_DEPRECATED -DGDK_VERSION_MIN_REQUIRED=GDK_VERSION_4_0 -DGDK_VERSION_MAX_ALLOWED=GDK_VERSION_4_0 -DGLIB_VERSION_MIN_REQ
UIRED=GLIB_VERSION_2_66 -DGLIB_VERSION_MAX_ALLOWED=GLIB_VERSION_2_66 -Wcast-align -Wdeclaration-after-statement -Werror=address -Werror=array-bounds -Werror=empty-body -Werror=implicit -Werror=implicit-function-declaration -Werror=init-self -Werror=int-conversion -Werror=int-to-point
er-cast -Werror=main -Werror=misleading-indentation -Werror=missing-braces -Werror=missing-include-dirs -Werror=nonnull -Werror=overflow -Werror=pointer-arith -Werror=pointer-to-int-cast -Werror=return-type -Werror=sequence-point -Werror=shadow -Werror=strict-prototypes -Werror=trigr
aphs -Werror=undef -Werror=write-strings -Wformat-nonliteral -Werror=format-security -Werror=format=2 -Wignored-qualifiers -Wimplicit-function-declaration -Wlogical-op -Wmissing-format-attribute -Wmissing-include-dirs -Wmissing-noreturn -Wnested-externs -Wno-cast-function-type -Wno-m
issing-field-initializers -Wno-sign-compare -Wno-unused-parameter -Wold-style-definition -Wpointer-arith -Wstrict-prototypes -Wswitch-default -Wswitch-enum -Wundef -Wuninitialized -Wunused -fno-strict-aliasing -Wmissing-declarations', '--ldflags=-L/home/mmoya/.cache/yay/gtksourceview
5/src/build/gtksourceview -Wl,-rpath,/home/mmoya/.cache/yay/gtksourceview5/src/build/gtksourceview -lgtksourceview-5 -lm -lfribidi -lglib-2.0 -lgobject-2.0 -lgio-2.0 -lgtk-4 -lpangocairo-1.0 -lpango-1.0 -lharfbuzz -lgdk_pixbuf-2.0 -lcairo-gobject -lcairo -lvulkan -lgraphene-1.0 -lxml
2 -lpangoft2-1.0 -lfontconfig -lfreetype -lpcre2-8 -Wl,-O1,--sort-common,--as-needed,-z,relro,-z,now -march=x86-64 -mtune=generic -O2 -pipe -fno-plt -fexceptions -Wp,-D_FORTIFY_SOURCE=2,-D_GLIBCXX_ASSERTIONS -Wformat -Werror=format-security -fstack-clash-protection -fcf-protection', 
'--cc=cc', '--ld=cc', '--output-dir=/home/mmoya/.cache/yay/gtksourceview5/src/build/docs/reference'] failed with status 1                                                                                                                                                                   
cc1: error: @BUILD_ROOT@/.: No such file or directory [-Werror=missing-include-dirs]                                                                                                                                                                                                        
cc1: error: @SOURCE_ROOT@/.: No such file or directory [-Werror=missing-include-dirs]
cc1: some warnings being treated as errors
2021-05-06 09:41:23,121:scangobj.py:execute_command:1289:WARNING:Compiling scanner failed: 1, command: cc -I@BUILD_ROOT@/. -I@SOURCE_ROOT@/. -I/usr/include/fribidi -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -pthread -I/usr/include/libmount -I/usr/include/blkid -I/usr/include
/gtk-4.0 -I/usr/include/pango-1.0 -I/usr/include/harfbuzz -I/usr/include/freetype2 -I/usr/include/libpng16 -I/usr/include/cairo -I/usr/include/lzo -I/usr/include/pixman-1 -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/graphene-1.0 -I/usr/lib/graphene-1.0/include -mfpmath=sse -msse -mss
e2 -I/usr/include/gio-unix-2.0 -I/usr/include/libxml2 -march=x86-64 -mtune=generic -O2 -pipe -fno-plt -fexceptions -Wp,-D_FORTIFY_SOURCE=2,-D_GLIBCXX_ASSERTIONS -Wformat -Werror=format-security -fstack-clash-protection -fcf-protection -DG_DISABLE_ASSERT -DG_DISABLE_CAST_CHECKS -DG_DI
SABLE_DEPRECATED -DGDK_DISABLE_DEPRECATED -DGTK_DISABLE_DEPRECATED -DGDK_PIXBUF_DISABLE_DEPRECATED -DGDK_VERSION_MIN_REQUIRED=GDK_VERSION_4_0 -DGDK_VERSION_MAX_ALLOWED=GDK_VERSION_4_0 -DGLIB_VERSION_MIN_REQUIRED=GLIB_VERSION_2_66 -DGLIB_VERSION_MAX_ALLOWED=GLIB_VERSION_2_66 -Wcast-al
ign -Wdeclaration-after-statement -Werror=address -Werror=array-bounds -Werror=empty-body -Werror=implicit -Werror=implicit-function-declaration -Werror=init-self -Werror=int-conversion -Werror=int-to-pointer-cast -Werror=main -Werror=misleading-indentation -Werror=missing-braces -We
rror=missing-include-dirs -Werror=nonnull -Werror=overflow -Werror=pointer-arith -Werror=pointer-to-int-cast -Werror=return-type -Werror=sequence-point -Werror=shadow -Werror=strict-prototypes -Werror=trigraphs -Werror=undef -Werror=write-strings -Wformat-nonliteral -Werror=format-se
curity -Werror=format=2 -Wignored-qualifiers -Wimplicit-function-declaration -Wlogical-op -Wmissing-format-attribute -Wmissing-include-dirs -Wmissing-noreturn -Wnested-externs -Wno-cast-function-type -Wno-missing-field-initializers -Wno-sign-compare -Wno-unused-parameter -Wold-style-
definition -Wpointer-arith -Wstrict-prototypes -Wswitch-default -Wswitch-enum -Wundef -Wuninitialized -Wunused -fno-strict-aliasing -Wmissing-declarations -c -o gtksourceview-5.0-scan.o gtksourceview-5.0-scan.c