Package Details: guile4emacs-git r17564.15ca78482-2

Git Clone URL: https://aur.archlinux.org/guile4emacs-git.git (read-only)
Package Base: guile4emacs-git
Description: patched version of guile for guile-emacs
Upstream URL: http://www.emacswiki.org/emacs/GuileEmacs
Licenses: GPL
Conflicts: guile-git
Provides: guile-git
Submitter: haawda
Maintainer: haawda
Last Packager: haawda
Votes: 4
Popularity: 0.000000
First Submitted: 2014-11-15 21:59
Last Updated: 2017-03-24 04:38

Latest Comments

linux40 commented on 2018-01-15 06:03

This package use the same directories as gulie, such as /usr/lib/guile/2.2, but .so files is not the same. So it may need to be changed to use other directories or to fully provide a guile.

VanLaser commented on 2017-09-15 13:21

With clang 4.0.1, configure fails ("can't make executable" error) unless I remove `-fvar-tracking-assignments` from DEBUG_CFLAGS and DEBUG_CXXFLAGS in /etc/makepkg.conf.

config.log:

clang-4.0: error: unknown argument: '-fvar-tracking-assignments'

I see this removing that flag is the standard solution when using clang, system-wide (https://wiki.archlinux.org/index.php/Clang)

belak commented on 2017-03-22 22:41

It looks like this may require openmp to be installed for at least building. I ran into this:


/usr/bin/ld: cannot find -lomp
clang-3.9: error: linker command failed with exit code 1 (use -v to see invocation)

haawda commented on 2016-12-17 12:38

git gives longer version numbers now, no need to update