Package Details: guipdftk 0.33-3

Git Clone URL: https://aur.archlinux.org/guipdftk.git (read-only)
Package Base: guipdftk
Description: GUI for PDFTK, lazarus-gtk2 needed
Upstream URL: http://www.paehl.de/pdf/gui_pdftk.html
Licenses: GPL
Submitter: None
Maintainer: None
Last Packager: haawda
Votes: 25
Popularity: 0.012814
First Submitted: 2008-08-28 20:24
Last Updated: 2015-06-08 22:24

Dependencies (2)

Required by (0)

Sources (3)

Latest Comments

bit commented on 2016-01-29 11:28

Free Pascal Compiler version 3.0.0 [2015/11/26] for x86_64
Copyright (c) 1993-2015 by Florian Klaempfl and others
(1002) Target OS: Linux for x86-64
(3104) Compiling project1.lpr
(3104) Compiling unit1.pas
/tmp/aur-guipdftk/src/unit1.pas(124,3) Error: (5000) Identifier not found "Shell"

bich_30 commented on 2015-02-26 14:01

It resolve!!

Open lazarus in cli (command line) and accept the warnings.

Open the Lazarus IDE and close.

restart the yaourt and OK!

wget commented on 2015-02-26 10:00

This package doesn't build any more. If someone could investigate.

==> Making package: guipdftk 0.33-3 (Thu Feb 26 10:59:14 CET 2015)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
-> Downloading linux_source.zip...
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
100 7944 100 7944 0 0 7025 0 0:00:01 0:00:01 --:--:-- 7030
-> Found guipdftk.desktop
-> Found guipdftk.config
==> Validating source files with md5sums...
linux_source.zip ... Passed
guipdftk.desktop ... Passed
guipdftk.config ... Passed
==> Extracting sources...
-> Extracting linux_source.zip with bsdtar
==> Starting build()...
x project1.lpi
x project1.lpr
x unit1.lfm
x unit1.lrs
x unit1.pas
primary config path: /home/wget/.lazarus
Error: invalid Lazarus directory "": directory lcl not found
Failed building project1.lpr
==> ERROR: A failure occurred in build().
Aborting...
==> ERROR: Makepkg was unable to build guipdftk.
==> Restart building guipdftk ? [y/N]

zoe commented on 2014-05-26 12:34

pdfchain is more recent, and package in AUR works well :
https://aur.archlinux.org/packages/pdfchain/

zoe commented on 2014-05-26 12:33

pdfchain is more recent, and package in AUR works well :

apinhal commented on 2013-03-05 00:48

makepkg fails with:
==> ERROR: install file ((guipdftk.install)) does not exist.

Changing the install variable in PKGBUILD to read:
install=${pkgname}.install

results in a succesful build.

Anonymous comment on 2012-10-22 14:38

For correct compilation I had to modify next lines:

Original:
install=(${pkgname}.install)
Modified:
install=${pkgname}.install

Original:
lazbuild project1.lpi
Modified:
lazbuild --lazarusdir=/usr/lib/lazarus project1.lpi

Results in a succesful build.

hexadecagram commented on 2012-03-13 21:15

makepkg fails with:
==> ERROR: install file ((guipdftk.install)) does not exist.

Changing the install variable in PKGBUILD to read:
install=${pkgname}.install

results in a succesful build.

Anonymous comment on 2011-05-22 18:36

Compatible with the architectures i686 and x86_64
Thank you BlueCore !