Package Details: guitar-pro 11686-1

Git Clone URL: https://aur.archlinux.org/guitar-pro.git (read-only)
Package Base: guitar-pro
Description: A popular tablature editor software for guitar, bass, and many other instruments.
Upstream URL: http://www.guitar-pro.com
Licenses: proprietary
Submitter: sergej
Maintainer: M0Rf30
Last Packager: M0Rf30
Votes: 29
Popularity: 0.812594
First Submitted: 2010-04-11 20:21
Last Updated: 2015-10-12 15:25

Dependencies (26)

Required by (0)

Sources (3)

Latest Comments

resetko commented on 2016-09-24 08:39

>> Hi, GuitarPro crashes for me as soon as I open a file or create a new one

Dsme problem :( total reinstall helps for some time

nipsky commented on 2016-08-29 06:22

@M0Rf30: Unfortunately, that didn’t help.

M0Rf30 commented on 2016-08-28 12:38

@nipsky
Could you try to remove flashplugin and restart GuitarPro?

nipsky commented on 2016-08-27 11:10

Hi, GuitarPro crashes for me as soon as I open a file or create a new one:

Object::connect: No such signal PlaySettingsWidget::tuningChanged() in /var/jenkins/workspace/guitar-pro-6-std-linux/gp/Sources/GuitarPro/widgets/UniverseSubWidget.cpp:133
Object::connect: No such signal BankListWidget::tuningChanged() in /var/jenkins/workspace/guitar-pro-6-std-linux/gp/Sources/GuitarPro/widgets/UniverseSubWidget.cpp:133
Object::connect: (sender name: 'SearchTreeWidget')
Object::connect: No such signal QWidget::tuningChanged() in /var/jenkins/workspace/guitar-pro-6-std-linux/gp/Sources/GuitarPro/widgets/UniverseSubWidget.cpp:133
Object::connect: (sender name: 'TrackMidiProperties')
[1] 24344 segmentation fault (core dumped) ./GuitarPro

I already tried applying another QT theme, without luck.

apaatsio commented on 2016-07-01 11:40

If you are having problems with Guitar Pro starting or crashing soon after startup, try switching to Adwaita theme. Helped me.

I'm using Manjaro Openbox, but I believe it's some GTK problem, so feel free to try this on other systems too :)

eduardo.tromer commented on 2016-06-30 17:53

Very good! :D

ftonello commented on 2016-04-10 22:20

If you have any libpng12 problems, you need to install both 32 and 64 bit versions from AUR:
https://aur.archlinux.org/packages/libpng12/
https://aur.archlinux.org/packages/lib32-libpng12/

apaatsio commented on 2015-10-08 11:44

I got my problems solved by using the linux version (not the demo) and modifying PKGBUILD to use that.

Instructions:

1. Click "Download snapshot"
2. Untar
3. Modify PKGBUILD (see below)
4. Run makepkg -si
5. Run /opt/GuitarPro6/GuitarPro
6. Happy shredding

Here are the modified parts in my PKGBUILD:

pkgver=11686
# ...
source=("http://downloads.guitar-pro.com/gp6/gp6-full-linux-r11686.deb"
"https://dl.dropboxusercontent.com/sh/29kr9dvw7gnmojk/AAC9yXcEWbxXgtBL5wUcgam_a/libcrypto.so.0.9.8"
"https://dl.dropboxusercontent.com/sh/29kr9dvw7gnmojk/AADCm1FBezXrR3ZosGBS8wUva/libssl.so.0.9.8")
# ...
md5sums=('3de3b59151b33965a92cd4f51162aeee'
'e66ee85eccfa5e5d0aabedcd13c6c8b4'
'8d7331135369f0dc131c4a95f034c4b7')

Note that this downloads the full version (not the demo/trial). I don't know if there is a difference, but I have the license key so this worked for me.

apaatsio commented on 2015-10-08 11:08

Please update the package version. Newest one is 11686. The one in this package is 11621.

rumpelsepp commented on 2015-09-16 20:32

Could you please use arch dependend fields, for instance depends_x86 and depends_i686 [1]? Using this CARCH magic breaks the AUR RPC interface [2]

[1]: https://www.archlinux.org/pacman/PKGBUILD.5.html#_options_and_directives
[2]: https://github.com/rmarquis/pacaur/issues/363#issuecomment-140840317

All comments