Package Details: gurobi 9.5.2-1

Git Clone URL: (read-only, click to copy)
Package Base: gurobi
Description: State-of-the-art solver for mathematical programming
Upstream URL:
Licenses: custom
Submitter: marcosmrai
Maintainer: marcosmrai (libklein)
Last Packager: libklein
Votes: 7
Popularity: 0.096909
First Submitted: 2016-08-10 19:35 (UTC)
Last Updated: 2022-07-07 14:05 (UTC)

Dependencies (5)

Required by (6)

Sources (3)

Latest Comments

Viech commented on 2021-01-27 14:40 (UTC)

Thank you for removing the hard dependency. Note though that by running "python install" you'll only get the Python 3 bindings, even if Python 2 is installed on the system. (Unless the system has not been updated in the last couple of years such that python = python2.) Thus it should be safe to remove also the optional dependency.

libklein commented on 2021-01-23 22:24 (UTC)

Python2 is not a hard dependency. I've made it optional.

terrificiceberg commented on 2020-12-03 11:52 (UTC)

Is python2 actually a hard dependency or could it be made optional? Right now gurobi is the only thing still depending on python2 on my system, and I would like to remove it.

Viech commented on 2020-09-14 16:19 (UTC)

==> Validating source files with sha256sums... gurobi9.0.3_linux64.tar.gz ... FAILED

uhrm commented on 2019-11-16 13:28 (UTC)

Update for Gurobi 8.1.1 and compatibility with Python 3.8:

JohnRobson commented on 2018-12-06 02:51 (UTC)

I edited the PKGBUILD for Python 3.7 and Gurobi 8.1 -

Viech commented on 2018-11-05 11:26 (UTC)

I just noticed due to this being flagged out of date that Gurobi 8.1 was released two weeks ago and it does claim to have Python 3.7 support. If now CPLEX follows then I can finally update my four-month-stale laptop. :-)

Viech commented on 2018-11-05 11:13 (UTC)

@lucasbrynte Gurobi does not support it (neither does CPLEX, by the way - from the three big commercial solvers, only MOSEK currently does).

The package claiming that python<3.8 is fine is actually incorrect, because even when the line with "python3.6" is changed to just "python3" (implying Python 3.7 on my system), then itself will raise a "RuntimeError: Unsupported Python version."

lucasbrynte commented on 2018-09-02 09:15 (UTC)

Is there any reason for holding back python<3.7?

Kindly, Lucas

jcd commented on 2017-08-31 16:23 (UTC) (edited on 2017-08-31 16:24 (UTC) by jcd)

There is a problem with the source stated in the PKGBUILD file. I guess its a typo? "ERROR: Unknown download protocol: file" Though when i provided the correct file the rest worked correctly.

lalitm commented on 2017-07-31 06:52 (UTC)

The .SRCINFO for the current package is not correct. It says that python2>=3.7 is required which obviously doesn't make any sense. Instead of manually editing the .SRCINFO file which is what it seems like is happening, the easier thing to do is simply run the "mksrcinfo" command which will generate the .SRCINFO from the PKGBUILD file automatically.

Turtizzle commented on 2017-06-20 15:06 (UTC)

You do not need to install the old python version for gurobi to work. The maintainer simply forgot to update the .SRCINFO file after updating the PKGBUILD, it still contains the old dependencies. Clone the repository and build the package manually instead of using an AUR helper to avoid this issue. (The respective scripts still need to be updated to 7.0.2 though, and I also think, the update to 7.0.1 is not complete... e.g., link to

jcd commented on 2017-06-06 14:33 (UTC) (edited on 2017-06-06 14:36 (UTC) by jcd)

It is possible to install python 3.5 from the AUR and adapt the PKBUILD to use python3.5, without requiring a general system downgrade to python 3.5. Only thing i had to fix post-install was: "/usr/bin/", which needs to run with python3.5 instead of python. Could you adapt it accordingly (after updating to 7.0.2)?

darnir commented on 2016-12-15 16:23 (UTC)

Could you please update the PKGBUILD for the latest release?