Package Details: gxneur 0.20.0-1

Git Clone URL: https://aur.archlinux.org/gxneur.git (read-only)
Package Base: gxneur
Description: GTK frontend for XNeur
Upstream URL: http://www.xneur.ru
Licenses: GPL
Submitter: None
Maintainer: cucullus
Last Packager: cucullus
Votes: 65
Popularity: 1.077884
First Submitted: 2006-11-15 21:39
Last Updated: 2016-12-03 16:45

Latest Comments

Genues commented on 2016-06-15 21:04

Thanks! It solved this problem, but now lost tray icon in Xfce.

Upd. Not solved - http://pastebin.com/raw/Hsdf4LAw

Upd2. On other my PC gxneur was updated and work fine. I look for the cause on first PC.

cucullus commented on 2016-06-15 20:32

gxneur should be built after new xneur installed

Genues commented on 2016-06-15 18:29

Houston, we have a problem
$ gxneur
gxneur: error while loading shared libraries: libxnconfig.so.17: cannot open shared object file: No such file or directory

$ yaourt libxnconfig
$

AlexWayfer commented on 2016-05-27 07:43

@bitnax, thanks! It's working.

bitnax commented on 2016-05-18 17:02

I got successful build only when I put the next line in PKGBUILD before "./configure ..." line:

CPPFLAGS="-Wno-misleading-indentation -Wno-unused-variable"

cobalt commented on 2012-11-21 10:16

I figured this out. To fix this problem one has to add --with-gtk=gtk2 to ./configure options in the PKGBUILD for xneur (note, not gxneur) package.

cobalt commented on 2012-11-21 09:35

One can use xneur instead of gxneur until the issue is resolved.

stmc commented on 2012-11-20 21:55

same problem
(gxneur:13328): Gtk-ERROR **: GTK+ 2.x symbols detected. Using GTK+ 2.x and GTK+ 3 in the same process is not supported

Genues commented on 2012-11-20 19:23

I have error on run: (gxneur:708): Gtk-ERROR **: GTK+ 2.x symbols detected. Using GTK+ 2.x and GTK+ 3 in the same process is not supported

P.S. Spasibo za ves'ma poleznuyu programmu!!! :)

Anonymous comment on 2012-11-10 09:32

0.16 is out. http://xneur.ru/news

VVS commented on 2012-07-11 08:10

2Petrovich: spasibo! :)

Anonymous comment on 2012-07-11 06:50

fix in PKGBUILD:
# Contributor: Sergey Kolesov <cucullus.at.mail.ru>
# Previously contributed by StormBlast and Vyazovoi

pkgname=gxneur
pkgver=0.15.0
pkgrel=1
pkgdesc="GTK frontend for XNeur"
url="http://www.xneur.ru"
arch=('i686' 'x86_64')
license=('GPL')
depends=('libglade' "xneur>=${pkgver}" 'hicolor-icon-theme' 'gconf')
source=("http://dists.xneur.ru/release-$pkgver/tgz/${pkgname}-${pkgver}.tar.bz2")
install=${pkgname}.install

md5sums=('ed749a4230339f28f42ae6dd28b762ab')


build() {
cd $startdir/src/${pkgname}-${pkgver}

sed -i 's/-Werror //' configure

./configure --prefix=/usr
make
make DESTDIR=${startdir}/pkg install
}

VVS commented on 2012-05-23 07:43

callbacks.c: В функции «on_key_press_event»:
callbacks.c:351:2: ошибка: «XKeycodeToKeysym» is deprecated (declared at /usr/include/X11/Xlib.h:1695) [-Werror=deprecated-declarations]
cc1: all warnings being treated as errors
make[2]: *** [gxneur-callbacks.o] Ошибка 1
make[2]: Выход из каталога `/tmp/yaourt-tmp-root/aur-gxneur/src/gxneur-0.15.0/src'
make[1]: *** [all-recursive] Ошибка 1
make[1]: Выход из каталога `/tmp/yaourt-tmp-root/aur-gxneur/src/gxneur-0.15.0'
make: *** [all] Ошибка 2
==> ОШИБКА: Произошел сбой в build().
Преждевременный выход...
==> ERROR: Makepkg was unable to build gxneur.

VVS commented on 2012-05-23 07:42

callbacks.c: В функции «on_key_press_event»:
callbacks.c:351:2: ошибка: «XKeycodeToKeysym» is deprecated (declared at /usr/include/X11/Xlib.h:1695) [-Werror=deprecated-declarations]
cc1: all warnings being treated as errors
make[2]: *** [gxneur-callbacks.o] Ошибка 1
make[2]: Выход из каталога `/tmp/yaourt-tmp-root/aur-gxneur/src/gxneur-0.15.0/src'
make[1]: *** [all-recursive] Ошибка 1
make[1]: Выход из каталога `/tmp/yaourt-tmp-root/aur-gxneur/src/gxneur-0.15.0'
make: *** [all] Ошибка 2
==> ОШИБКА: Произошел сбой в build().
Преждевременный выход...
==> ERROR: Makepkg was unable to build gxneur.

Anonymous comment on 2012-05-21 17:45

When will the new version be released?

Aspiring commented on 2012-04-27 14:09

"gxneur: error while loading shared libraries: libpcre.so.0: cannot open shared object file: No such file or directory"
>>>
#cd /usr/lib/
#cp libpcre.so libpcre.so.0
Enjoy!

Aspiring commented on 2012-04-27 14:02

"gxneur: error while loading shared libraries: libpcre.so.0: cannot open shared object file: No such file or directory"
>>>
#cd /usr/lib/
#cp libpcre.so libpcre.so.0
Enjoy!

Anonymous comment on 2012-03-20 18:49

But you maybe could make a bugfix release?
I'm installing with yaourt, and when i edit the Makefile and try again, the archive unpacks again and the Make overrites...

cucullus commented on 2012-03-20 14:25

Ask devs about new versions.

To fix compilation errors try to delete -Wall or something like that in CFLAGS (in Makefile)

Anonymous comment on 2012-03-20 11:42

OK, when will it arrive?
When wiil be the compile bug fixed?

cucullus commented on 2012-03-19 15:08

Dmitry, please do not flag until new version arrives.

Anonymous comment on 2012-03-17 16:38

event.c: In function 'event_get_cur_keysym':
event.c:144:2: error: 'XKeycodeToKeysym' is deprecated (declared at /usr/include/X11/Xlib.h:1695) [-Werror=deprecated-declarations]
cc1: all warnings being treated as errors
make[3]: *** [libxnmain_la-event.lo] Ошибка 1
make[3]: Выход из каталога `/tmp/yaourt-tmp-dmitry/aur-xneur/src/xneur-0.15.0/lib/main'
make[2]: *** [all-recursive] Ошибка 1
make[2]: Выход из каталога `/tmp/yaourt-tmp-dmitry/aur-xneur/src/xneur-0.15.0/lib'
make[1]: *** [all-recursive] Ошибка 1
make[1]: Выход из каталога `/tmp/yaourt-tmp-dmitry/aur-xneur/src/xneur-0.15.0'
make: *** [all] Ошибка 2
==> ОШИБКА: Произошел сбой в build().
Преждевременный выход...
==> ERROR: Makepkg was unable to build xneur.

VVS commented on 2012-03-03 17:21

gxneur: error while loading shared libraries: libpcre.so.0: cannot open shared object file: No such file or directory

VVS commented on 2012-03-03 17:16

gxneur: error while loading shared libraries: libpcre.so.0: cannot open shared object file: No such file or directory

Anonymous comment on 2012-02-22 03:21

Quick fix to compile vs. libx11 1.4.99.1

https://gist.github.com/1881050

Spilver commented on 2011-11-28 13:23

When configuring:
"checking for XNEURCONF... configure: error: Package requirements (xnconfig = 0.15.0) were not met:
No package 'xnconfig' found"

And package 'xnconfig' not available in AUR/REPOs

Please check it

Anonymous comment on 2011-11-16 08:43

New version was released