Package Details: gzdoom 4.7.1-1

Git Clone URL: https://aur.archlinux.org/gzdoom.git (read-only, click to copy)
Package Base: gzdoom
Description: Feature centric port for all Doom engine games
Upstream URL: http://www.zdoom.org/
Licenses: GPL3, BSD, LGPL3
Replaces: gzdoom-legacy, gzdoom1
Submitter: None
Maintainer: grubber
Last Packager: grubber
Votes: 128
Popularity: 1.38
First Submitted: 2009-02-22 22:28
Last Updated: 2021-10-21 15:10

Dependencies (28)

Sources (3)

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 ... Next › Last »

annoyingduck commented on 2021-05-23 13:30

Just updated to 4.6.0-1. Still having the same MESA issue on XFCE w/intel graphics. GZdoom will not run at all. I have to downgrade MESA to 21.0.2-1. GZdoom fires right up after downgrade. I'm not sure where else to post this.

HurricanePootis commented on 2021-05-23 01:49

I updated the PKGBUILD for you, and I also disabled Anon stats sending (if that's what you want)

# Maintainer: Jan Cholasta <grubber at grubber cz>
# Contributor: Christoph Zeiler <rabyte*gmail>
# Contributor: HurricanePootis <hurricanepootis@protonmail.com>

pkgname=gzdoom
pkgver=4.6.0
pkgrel=1
pkgdesc='Feature centric port for all Doom engine games'
arch=('i686' 'x86_64')
url='http://www.zdoom.org/'
license=('BSD' 'GPL3' 'LGPL3')
depends=('gtk3'
         'hicolor-icon-theme'
         'libgl'
         'libjpeg'
         'openal'
         'sdl2'
         'zmusic>=1.1.1')
makedepends=('cmake' 'desktop-file-utils' 'git')
optdepends=('blasphemer-wad: Blasphemer (free Heretic) game data'
            'chexquest3-wad: Chex Quest 3 game data'
            'doom1-wad: Doom shareware game data'
            'freedm: FreeDM game data'
            'freedoom1: Freedoom: Phase 1 game data'
            'freedoom2: Freedoom: Phase 2 game data'
            'gxmessage: crash dialog (GNOME)'
            'hacx-wad: HacX game data'
            'harmony-wad: Harmony game data'
            'heretic1-wad: Heretic shareware game data'
            'hexen1-wad: Hexen demo game data'
            'kdialog: crash dialog (KDE)'
            'strife0-wad: Strife shareware game data'
            'square1-wad: The Adventures of Square, Episode 1 game data'
            'urbanbrawl-wad: Urban Brawl: Action Doom 2 game data'
            'xorg-xmessage: crash dialog (other)')
optdepends_x86_64=('vulkan-driver: Vulkan renderer'
                   'vulkan-icd-loader: Vulkan renderer')
replaces=("gzdoom1")
source=("gzdoom::git://github.com/coelckers/gzdoom.git#tag=g${pkgver}"
        'gzdoom.desktop')
sha256sums=('SKIP'
            '59122e670f72aa2531aff370e7aaab2d886a7642e79e91f27a533d3b4cad4f6d')
prepare() {
    cd gzdoom
    git submodule update --init
}

build() {
    cd gzdoom
    mkdir -p build
    cmake -B build \
          -D CMAKE_BUILD_TYPE=Release \
          -D CMAKE_CXX_FLAGS="${CXXFLAGS} -ffile-prefix-map=\"$PWD\"=. -DSHARE_DIR=\\\"/usr/share/gzdoom\\\"" \
          -D DYN_GTK=OFF \
          -D DYN_OPENAL=OFF \
      -D SEND_ANON_STATS=OFF

    make -C build
}

package() {
    cd gzdoom
    install build/gzdoom -t "$pkgdir"/usr/bin -D
    install build/{game_support,gzdoom}.pk3 -t "$pkgdir"/usr/lib/gzdoom -D -m 644
    desktop-file-install "$srcdir"/gzdoom.desktop --dir="$pkgdir"/usr/share/applications
    install docs/{console,rh-log,skins}.* -t "$pkgdir"/usr/share/doc/gzdoom -D -m 644
    install build/{brightmaps,game_widescreen_gfx,lights}.pk3 -t "$pkgdir"/usr/share/gzdoom -D -m 644
    install build/soundfonts/gzdoom.sf2 -t "$pkgdir"/usr/share/gzdoom/soundfonts -D -m 644
    install build/fm_banks/* -t "$pkgdir"/usr/share/gzdoom/fm_banks -D -m 644
    install src/posix/zdoom.xpm "$pkgdir"/usr/share/icons/hicolor/256x256/apps/gzdoom.xpm -D -m 644
    install docs/licenses/{bsd,fxaa,gdtoa,README}.* -t "$pkgdir"/usr/share/licenses/$pkgname -D -m 644
}

annoyingduck commented on 2021-05-04 16:14

Update to my post yesterday. It's the MESA update that breaks Gzdoom. A downgrade of mesa to the last package gets Gzdoom working again for me.

annoyingduck commented on 2021-05-03 18:05

Anyone else able to run GZDoom after recent system updates May 03 2021? I tried rebuilding GZdoom and Zmusic...no luck. It just won't fire up for me. Running GZdoom from the terminal brings up the iWAD selection screen then after selecting the terminal kicks back an audio error, but then seems to resolve it. When the terminal commands get to using video driver x11, the commands stop and it kills itself.

likeninja commented on 2020-12-11 18:23

I'm not getting the dialouge box that let's you select which IWAD to use, even though I have several in my folder.

grubber commented on 2020-11-28 07:12

homk, zmusic is available in AUR: https://aur.archlinux.org/packages/zmusic/

terrytuden114, did you use makepkg or some AUR helper such as yaourt?

homk commented on 2020-11-26 22:19

@terrytuden114 , so install it manually. Worked for me.

Anyway, you should ping zmusic developers to include the package to repository. That's not the gzdoom issue.

terrytuden114 commented on 2020-11-16 07:28

doesnt work fails to resolve gzmusic thanks for that

alfrednewman commented on 2020-07-26 22:37

If GZDoom crashes on launch and you're using KDE, you will need to install kdialog using sudo pacman -S kdialog

It needs that to popup a window, most likely telling you it can't find a IWAD

parkerlreed commented on 2020-03-18 16:20

@grubber Thanks! Yeah I had a brainfart and was using git. I see where that was updated. Cheers.