Package Details: ha-glue 1.0.12-8

Git Clone URL: https://aur.archlinux.org/ha-glue.git (read-only, click to copy)
Package Base: ha-glue
Description: A set of libraries, tools and utilities suitable for the Heartbeat/Pacemaker cluster stack.
Upstream URL: https://github.com/ClusterLabs/cluster-glue
Licenses: GPL
Submitter: None
Maintainer: insanemal
Last Packager: insanemal
Votes: 5
Popularity: 0.000004
First Submitted: 2010-09-03 10:09 (UTC)
Last Updated: 2023-07-31 00:25 (UTC)

Latest Comments

1 2 Next › Last »

jamincollins commented on 2024-03-22 13:52 (UTC)

Python 2.x reached end of life January 1st, 2020.

The cluster-glue source appears to have 4 python files. Those files have been updated in the upstream git repository for Python 3. I've requested an updated tag/release: https://github.com/ClusterLabs/cluster-glue/issues/41

However, I believe the changes for Python 3.x are contained within these two commits: * https://github.com/ClusterLabs/cluster-glue/commit/2e09b707e4761943d64108ebe1dc6492e305b676 * https://github.com/ClusterLabs/cluster-glue/commit/6421b85ade01709aa0a735fca475bf262cc980ff

If these were taken as patches until a new release/tag was made, the dependency on Python 2.x could be dropped.

insanemal commented on 2023-06-20 02:04 (UTC)

The source no longer exists. This needs to be updated.

omgold commented on 2020-08-02 07:27 (UTC)

A newer version of the program /usr/bin/cibsecret is included in the most recent pacemaker package (2.0.4), thus there is a conflict. Could it be removed from ha-glue?

joekhoobyar commented on 2018-11-30 21:12 (UTC)

Errors in most recent build, complained that the following commands had to be run before compiling:

groupadd -r -g 666 haclient

useradd -r -g haclient -u 666 -d /var/lib/heartbeat/cores/hacluster -s /sbin/nologin -c "cluster user" hacluster

I don't like how the upstream requires installation steps to happen before compiling

ghostlovescore commented on 2017-09-10 09:48 (UTC)

Thanks @mattski! I have updated PKGBUILD.

mattski commented on 2017-09-09 09:47 (UTC)

I believe the util-linux-ng should be changed to util-linux, as util-linux-ng has been renamed to replace util-linux

ghostlovescore commented on 2015-03-14 20:20 (UTC)

Updated. Sorry for delay.

jyellick commented on 2015-03-11 19:01 (UTC)

With the updates to the filesystem package, /usr/sbin and /usr/lib64 are now symlinks. The ./configure needs to be updated to include --sbindir=/usr/bin and --libdir=/usr/lib .

Alwin commented on 2013-05-19 14:39 (UTC)

ddelpino & user00265, i had the same problem. i added some sed to the PKGBUILD. after that it successfully compiled and installed the package. but i didn't test it yet. sed -i 's/<glib\/gtypes\.h>/<glib\.h>/g' include/clplumbing/cl_uuid.h sed -i 's/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/g' configure.ac # added this line ./autogen.sh

<deleted-account> commented on 2013-04-02 13:13 (UTC)

Same problem: aclocal configure.ac:44: error: 'AM_CONFIG_HEADER': this macro is obsolete. You should use the 'AC_CONFIG_HEADERS' macro instead. /usr/share/aclocal-1.13/obsolete-err.m4:12: AM_CONFIG_HEADER is expanded from... configure.ac:44: the top level autom4te: /usr/bin/m4 failed with exit status: 1 aclocal: error: echo failed with exit status: 1 ./autogen.sh exiting due to error (sorry!). ==> ERROR: Se produjo un error en build(). Cancelando...