Package Details: ha-pacemaker-git Pacemaker.1.1.7.4159.g622f276-2

Git Clone URL: https://aur.archlinux.org/ha-pacemaker-git.git (read-only, click to copy)
Package Base: ha-pacemaker-git
Description: Pacemaker is an cluster resource manager
Upstream URL: http://linux-ha.org/wiki/Pacemaker
Licenses: GPL
Submitter: ghostlovescore
Maintainer: ghostlovescore
Last Packager: ghostlovescore
Votes: 5
Popularity: 0.000000
First Submitted: 2015-03-07 17:02 (UTC)
Last Updated: 2015-07-05 09:38 (UTC)

Latest Comments

ghostlovescore commented on 2016-08-26 20:26 (UTC)

Hi @mattski, I will take a look as soon as I return from vacation. :)

mattski commented on 2016-08-24 11:41 (UTC)

I was only able to get this to install with the dependency libqb-git installed (this did not work with the libqb in AUR).

ghostlovescore commented on 2015-12-05 16:32 (UTC)

Hi @Nefelim4ag, Can you please try to update libqb package. I managed to build ha-pacemaker-git package ony my test server with libqb=0.14.3-3 (did not update it for a while). Thanks

Nefelim4ag commented on 2015-12-05 14:28 (UTC)

hi, it's wont build: checking for qb/qbipc_common.h... yes checking for qb_ipcs_connection_auth_set in -lqb... yes checking for qb_ipcs_connection_get_buffer_size... yes configure: error: in `/tmp/yaourt-tmp-build/aur-ha-pacemaker-git/src/pacemaker': configure: error: Version of libqb is too old: v0.13 or greater requried See `config.log' for more details ==> ERROR: A failure occurred in build(). Aborting... ==> ERROR: Makepkg was unable to build ha-pacemaker-git. ==> Restart building ha-pacemaker-git ? [y/N] ==> ----------------------------------------- ==> I use https://aur.archlinux.org/packages/libqb/ if it's a problem on my side, may be you know how to fix it?

oliviernicaise commented on 2015-04-30 13:01 (UTC)

pacemaker.service is wrong as is. Type=forking should not be part of it as the daemon is not forking

jyellick commented on 2015-03-11 20:46 (UTC)

There are a couple problems with the current PKGBUILD around the symlinks of /usr/sbin /usr/lib64 and /var/run. These can be fixed by setting --sbindir=/usr/bin --libdir=/usr/lib and changing _PREFIXVAR to be /run instead of /var. I was having some stability problems with the older pacemaker, so also needed to bump up to 1.1.12, see http://pastebin.com/FTpf277z for my modified PKGBUILD.

ghostlovescore commented on 2015-01-06 08:51 (UTC)

Hello, Pacemaker will be updated ASAP. Sorry for delay.

deons commented on 2015-01-05 20:08 (UTC)

Hi Pacemaker 1.1.12 is available

psi-jack commented on 2012-12-23 21:41 (UTC)

Updated to 1.1.8 git commit 3f6e0f0ec7 This resolves the DNS PTR issues that 1.1.8 official had incurred and provides a more sound systemd service unit non-dependent on the old init script it was wrapping around prior to.

psi-jack commented on 2012-12-22 19:11 (UTC)

There's a serious bug in this version of Pacemaker that I'm going to end up temporarily replacing it with a version directly from git. Basically in short, this version started doing DNS lookups (which is bad), and completely fails when you have a fully functional DNS structure setup, with A and PTR records. This functionality has been ripped back out in later versions, but not yet in any release version, specifically. I don't know how many people are using Pacemaker and Arch Linux together, so, keep that in mind, at least until 1.1.8-$date is up here.

psi-jack commented on 2012-11-23 10:01 (UTC)

Version bumped to 1.1.8

commented on 2011-10-08 13:00 (UTC)

I think ha-pacemaker should also depend on ha-resourceagent. I can not install ha-pacemaker sucessfully until I installed ha-resourceagent.

commented on 2011-03-15 16:33 (UTC)

update if you have an error when run crm try to use crm2

commented on 2010-11-19 20:06 (UTC)

for now add this after the line: make DESTDIR="${pkgdir}" install || return 1 #python path correction for py in `grep -r -l "\#\!\/usr\/bin\/python" ${pkgdir}`;do sed -i.bk 's:/usr/bin/python:/usr/bin/python2:g' ${py} done

commented on 2010-11-17 12:16 (UTC)

I don't have experience whit patch file, you can help me?

commented on 2010-11-14 06:33 (UTC)

This package should depend on python2, /usr/sbin/crm doesn't work with python 3 unmodified and it's the new arch default. The relevant python scripts should probably also be patched with a new #! declaration.