Package Details: hackrf-git 2021.03.1.r192.gdfadf6a3-1

Git Clone URL: https://aur.archlinux.org/hackrf-git.git (read-only, click to copy)
Package Base: hackrf-git
Description: Driver for HackRF, allowing general purpose software defined radio (SDR).
Upstream URL: https://github.com/mossmann/hackrf
Licenses: GPL2
Conflicts: hackrf
Provides: hackrf
Submitter: m3thodic
Maintainer: m3thodic
Last Packager: m3thodic
Votes: 0
Popularity: 0.000000
First Submitted: 2017-11-11 06:49 (UTC)
Last Updated: 2022-06-03 07:40 (UTC)

Required by (22)

Sources (2)

Latest Comments

EndlessEden commented on 2022-01-24 15:32 (UTC)

@m3thodic - Missing depend python-yaml (error was a yaml import failure)

m3thodic commented on 2021-09-30 06:27 (UTC)

@Potomac updated the makedepends array, thanks. the cmake flags are required for building the actual firmware but I removed them when building the binaries.

Potomac commented on 2021-04-27 09:10 (UTC)

This package needs dependencies packages for compiling : arm-none-eabi-gcc and arm-none-eabi-newlib, please update the PKGBUILD file like this :

makedepends=('cmake' 'dfu-util' 'arm-none-eabi-gcc' 'arm-none-eabi-newlib')

and you don't need to specify -DCMAKE_C_FLAGS and -DCMAKE_CXX_FLAGS, just do like the regular package of harckrf :

https://github.com/archlinux/svntogit-community/blob/packages/hackrf/trunk/PKGBUILD

mgisbers commented on 2019-06-23 22:19 (UTC) (edited on 2019-06-23 22:19 (UTC) by mgisbers)

Hi, git is also missing from makedepends.

m3thodic commented on 2018-06-21 19:32 (UTC)

@lacouture Just pushed an update, thanks!

lacouture commented on 2018-06-21 08:52 (UTC) (edited on 2018-06-21 08:53 (UTC) by lacouture)

Hi, it seems that dfu-util is missing from makedepends.

The patch below fixes this:

diff --git a/PKGBUILD b/PKGBUILD
index f69326c..32f95ae 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@ arch=('i686' 'x86_64')
 url="https://github.com/mossmann/hackrf"
 license=('GPL2')
 depends=('libusb' 'fftw')
-makedepends=('cmake')
+makedepends=('cmake' 'dfu-util')
 conflicts=('hackrf')
 provides=('hackrf')
 source=("$pkgname::git+https://github.com/mossmann/hackrf" 'hackrf.conf')

Regards

OpenSourceLego commented on 2018-06-14 05:39 (UTC)

Ok, next issue was the presence of 32bit file in package, blinky_0.elf, error is can't identify format of file...wonder why... I have moved to the github repo https://github.com/mossmann/hackrf.git and installed via this, seems to be working all compiled hackrf tools are present. Will advise when I finish testing now. Again, figured I would drop this here anyway.

OpenSourceLego commented on 2018-06-14 05:11 (UTC)

If it helps, this dependency arm-none-eabi-newlib is also required (to back up FFY00's comment). Moved me along to the next issue, currently working on it, but figured I would comment before I forgot to.

FFY00 commented on 2018-05-19 20:53 (UTC)

Missing dependencies python-pyaml, arm-none-eabi-gcc and the arm libc, which I don't know the name.