Package Details: hal-flash 0.3.3-1

Git Clone URL: https://aur.archlinux.org/hal-flash.git (read-only)
Package Base: hal-flash
Description: A libhal stub library forwarding to UDisks2 for flash to play DRM content
Upstream URL: https://github.com/cshorler/hal-flash
Licenses: GPL2
Conflicts: hal
Provides: hal=0.5.14
Submitter: freonmonkey
Maintainer: freonmonkey
Last Packager: freonmonkey
Votes: 53
Popularity: 3.417216
First Submitted: 2013-12-26 21:26
Last Updated: 2016-03-25 16:20

Required by (2)

Sources (1)

Latest Comments

freonmonkey commented on 2015-08-29 15:03

Updated to 0.3.2. The download link is now pkgver-dependent, as suggested. I left in the 'provides hal' to implicitly conflict with anything else that does. (If any other projects provide a hal impelmentation, it'll conflict with this without having to be named explicitly as a conflicting package.)

TrialnError commented on 2015-07-03 10:52

I see. Thought a bit about the provides entry. Not sure anymore if it should be there. Conflicts is right, because of conflicting files. But this package doesn't replace/provides hal as like the hal package would be? Just one functionality out of many.

And if you replace the 0.3.1 in the source link with ${pkgver} you don't need to change the number in two places (and it happened before, that pkgver got adjusted but the download url not).

freonmonkey commented on 2015-07-03 03:16

Updated to 0.3.1 and tidied up the PKGBUILD.

@TrailInErro: I initially gave it 0.5.15 so that it would look like an upgrade over hal. Since it's actually based on the 0.5.14 libraries, I've changed the hal version to 0.5.14.

TrialnError commented on 2015-07-02 14:52

Additionally about removing the packages from base and base-devel from depends, is there a typo in the provides line? Latest hal release would be 0.5.14 and not 0.5.15

Edit: And why is git in the makedepends? This PKGBuild does not clone the repo.
And empty vars should be removed (in this case group)

TrialnError commented on 2015-07-02 14:48

Additionally about removing the packages from base and base-devel from depends, is there a typo in the provides line? Latest hal release would be 0.5.14 and not 0.5.15

Bevan commented on 2015-03-21 09:57

All packages from the base-devel group are assumed to be installed if you build packages from AUR. They should not be added to makedepends:
https://wiki.archlinux.org/index.php/PKGBUILD#makedepends

OssiL commented on 2015-03-21 05:50

This requires also automake to be installed, so better add it as dependency.

freonmonkey commented on 2015-01-04 20:07

Thanks for the new version notices; I'm working on the new package today.

deusstultus commented on 2015-01-04 09:28

I didn't dig at pacman code to identify root cause or why this was present here at all, but options=('') should be purged from hal-flash and hal-flash-git as it is not compatible with current makepkg release.

Bevan commented on 2015-01-02 22:21

On github there is a tagged version 0.3.0 now including downloadable zip and tar.gz files.

All comments