Package Details: hamlib-git r9033.afabcfff-3

Git Clone URL: https://aur.archlinux.org/hamlib-git.git (read-only, click to copy)
Package Base: hamlib-git
Description: Ham radio equipment control libraries - GIT VER 4.x - NO INDI SUPPORT
Upstream URL: http://hamlib.org
Licenses: GPL, LGPL
Conflicts: hamlib, hamlib4
Provides: hamlib, hamlib4
Submitter: CarstenF
Maintainer: not_anonymous
Last Packager: not_anonymous
Votes: 5
Popularity: 0.000000
First Submitted: 2014-09-10 22:18 (UTC)
Last Updated: 2022-07-31 19:05 (UTC)

Required by (41)

Sources (1)

Latest Comments

not_anonymous commented on 2022-07-31 19:07 (UTC)

Added in git as a makedepends AND libindi-support.

djpohly commented on 2022-07-25 05:36 (UTC)

This is still missing the git package in makedepends.

not_anonymous commented on 2022-06-28 21:21 (UTC)

Removed "support" for libindi (indi). wsjt-x requires, at this time, this compile time "removal". NOTE: the hamlib4 PKGBUILD still supports "indi", as does the binary package in the community repo.

not_anonymous commented on 2021-08-23 06:40 (UTC)

Updated !!

not_anonymous commented on 2021-08-18 12:44 (UTC) (edited on 2021-08-18 12:45 (UTC) by not_anonymous)

Just adopted this (once again)....will be working on it...TIA for your patience.

grawlinson commented on 2021-08-02 22:44 (UTC)

Any chance of using Python 3 instead of the long-dead Python 2?

FabioLolix commented on 2021-07-25 07:44 (UTC)

This is missing git in makedepends and need a proper pkgver function https://wiki.archlinux.org/title/VCS_package_guidelines#Git

not_anonymous commented on 2021-06-07 22:17 (UTC)

Updated !

micwoj92 commented on 2021-04-22 21:26 (UTC)

Needs git in makedepends

hoeste commented on 2018-07-19 04:37 (UTC)

The build fails with the error "/bin/pacman: unrecognized option '--color never'". I thought it was a hamlib dependency that was the issue because trying to install just that gave this error too. But hamlib-git installed fine. After that, trying this build again gave the same error.

not_anonymous commented on 2018-04-21 15:19 (UTC)

Thanks for the "heads-up" Tom. 'autoreconf -i' was needed to generate the missing ./configure file. I also updated the perl stuff.

tom.swartz07 commented on 2018-04-03 12:41 (UTC)

Build seems to be broken.

They've moved from ./autogen .... to using ./configure

not_anonymous commented on 2017-02-01 00:04 (UTC) (edited on 2017-02-01 00:05 (UTC) by not_anonymous)

New package. THREE comments; 1 - Needed as some packages (that use hamlib) are ONLY python3 programs. 2 - I felt it was useful, so I added in all the former contributors of hamlib. 3 - Fixed various depends and provides/conflicts as needed.