Package Details: hammerfight 1:1.004-1

Git Clone URL: (read-only)
Package Base: hammerfight
Description: A 2D physics-based video game in which you swing large melee weapons to destroy enemies (game sold separately)
Upstream URL:
Licenses: custom
Groups: humblebundle3, humblebundle4, humblebundles
Submitter: gadget3000
Maintainer: ejona86
Last Packager: ejona86
Votes: 29
Popularity: 0.004163
First Submitted: 2011-07-26 21:53
Last Updated: 2015-06-20 16:12

Latest Comments

Marvn commented on 2012-01-25 17:07

you should change install=('hammerfight.install') --> install='hammerfight.install'

Marvn commented on 2012-01-25 17:00

there is version 1.004 now on hib page. you should also change install=('hammerfight.install') --> install='hammerfight.install'

Marvn commented on 2012-01-25 16:56

there is version 1.004 now on hib page

Anonymous comment on 2011-12-31 16:41

It's just dawned on me that you maintain most of the HIB3 packages. You probably already know what I'm going to say about _humblebundle4key.

intgr commented on 2011-08-12 22:56

New pkgbuild here:

PS: please use variables to refer to version numbers, instead of copy-and-paste coding

cookiecaper commented on 2011-08-12 22:19

Sorry about that gadget. The new build has been published now:

Anonymous comment on 2011-08-11 17:25

How about adding an environment variable that lets you define where the archive file is located? This would make installation without key easier since you wouldn't need to copy the file to $srcdir. Also, the existence of the file should be checked before attempting to run md5sum to prevent ugly errors. An example PKGBUILD implementing both features:

gadget3000 commented on 2011-08-10 07:56

@cookiecaper There hasn't been an update on my bundle download page. Build number is still 07172011 and the md5sum hasn't changed.

cookiecaper commented on 2011-08-10 02:32

Build version is still 20111707 . icculus indicated several days ago that a new build would be uploaded to the Humble Bundle site within a day. Has this build yet been accounted for? I would like the MD5 and version number updated, for instance.

intgr commented on 2011-08-06 16:36

You should use this to support dependencies on 64-bit:

[ "$CARCH" = "i686" ] && depends=('openal' 'gcc-libs' 'sdl')
[ "$CARCH" = "x86_64" ] && depends=('lib32-openal' 'lib32-gcc-libs' 'lib32-sdl')

gadget3000 commented on 2011-07-28 19:31

Wow, amateur mistake. Fixed.

Anonymous comment on 2011-07-28 18:55

Hello, there is an error on the hammerfight.desktop
"Name=Cogs" instead of "Name=Hammerfight" on the file.