Package Details: hardcode-tray 4.3-1

Git Clone URL: https://aur.archlinux.org/hardcode-tray.git (read-only)
Package Base: hardcode-tray
Description: Fixes Hardcoded Tray Icons
Upstream URL: https://github.com/bil-elmoussaoui/Hardcode-Tray
Licenses: GPL-3.0
Conflicts: hardcode-tray-fixer-git, hardcode-tray-git
Provides: hardcode-tray
Submitter: bil-elmoussaoui
Maintainer: liljaylj
Last Packager: liljaylj
Votes: 23
Popularity: 0.290436
First Submitted: 2016-11-14 17:44
Last Updated: 2018-09-29 20:20

Latest Comments

« First ‹ Previous 1 2

mareex commented on 2017-01-21 11:46

Does this actually work for someone?

I always get:

marcus@NUC6I5SYH ~ % hardcode-tray --conversion-tool Inkscape --theme Papirus-Dark
[sudo] Passwort für marcus:
Welcome to the tray icons hardcoder fixer!
Your indicator icon size is : 22
Your current icon theme is : Papirus-Dark
Svg to png functions are : Enabled
Conversion tool : Inkscape
Applications will be fixed : All
1 - Apply
2 - Revert
Please choose: 1
Applying now..

Traceback (most recent call last):
File "script.py", line 320, in <module>
install(fix_only, icon_path)
File "script.py", line 199, in install
apps = get_supported_apps(fix_only, custom_path)
File "script.py", line 140, in get_supported_apps
custom_path, is_only)
File "/opt/Hardcode-Tray/modules/data.py", line 51, in __init__
self.read()
File "/opt/Hardcode-Tray/modules/data.py", line 87, in read
self.get_app_icons()
File "/opt/Hardcode-Tray/modules/data.py", line 99, in get_app_icons
self.default_icon_size)
File "/opt/Hardcode-Tray/modules/icon.py", line 44, in __init__
self.read()
File "/opt/Hardcode-Tray/modules/icon.py", line 63, in read
orig_icon = self.icon_data["original"]
TypeError: list indices must be integers or slices, not str

doskoi commented on 2017-01-14 18:11

@bil-elmoussaoui whoops you're right, I reported it.

bil-elmoussaoui commented on 2017-01-13 03:44

@doskoi this should be rather added to inkscape insteadd of hardcode-tray. Using inkscape is optional, you can use other conversion tools if you wish. (CairoSVG, librsvg, ImageMagick...)

doskoi commented on 2017-01-12 08:36

I think that the gnome-themes-standard package is required here. Without it, I get these errors:

fixing failed with error:

(inkscape:17504): Gtk-WARNING **: Unable to locate theme engine in module_path: "adwaita",

(inkscape:17504): Gtk-WARNING **: Unable to locate theme engine in module_path: "adwaita",

(inkscape:17504): Gtk-WARNING **: Unable to locate theme engine in module_path: "adwaita",

(inkscape:17504): Gtk-WARNING **: Unable to locate theme engine in module_path: "adwaita",

bil-elmoussaoui commented on 2017-01-06 01:36

@evilgnome fixed! sorry for that :)

andykluger commented on 2017-01-05 17:48

The latest release on github is 3.6.3, so this pkgbuild fails, being from the future.