Package Details: haskell-alsa-core 0.5.0.1-4

Git Clone URL: https://aur.archlinux.org/haskell-alsa-core.git (read-only)
Package Base: haskell-alsa-core
Description: Provides access to ALSA infrastructure
Upstream URL: https://hackage.haskell.org/package/alsa-core
Licenses: BSD
Submitter: brofi
Maintainer: brofi (pdxleif)
Last Packager: brofi
Votes: 4
Popularity: 0.001195
First Submitted: 2016-04-06 19:52
Last Updated: 2017-09-29 21:25

Latest Comments

SolarAquarion commented on 2018-06-07 18:18

you need to add alsa as a dependency

EntilZha commented on 2017-11-21 19:24

Didn't notice your (quick) response. Finally got things working, root issue seemed to be a messed up ghc which in the end was fixed by completely nuking all my ghc/haskell related things and reinstalling from scratch.

brofi commented on 2017-11-11 19:18

haskell-alsa-core and haskell-alsa-mixer have been updated to work with ghc 8.0.2-1 (changes with linking). For me the build works just fine with ghc 8.2.1-3 as well. I don't mess around with cabal too much, but extensible-exceptions is listed by both the commands you posted on my system.

EntilZha commented on 2017-11-11 00:06

I am running into this issue below which seems odd. Is this possibly related to ghc-8 changes with linking, or is it more likely to be something I messed up?

$ makepkg -si
==> Making package: haskell-alsa-core 0.5.0.1-4 (Fri Nov 10 16:56:40 MST 2017)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
-> Found alsa-core-0.5.0.1.tar.gz
==> Validating source files with sha256sums...
alsa-core-0.5.0.1.tar.gz ... Passed
==> Extracting sources...
-> Extracting alsa-core-0.5.0.1.tar.gz with bsdtar
==> Removing existing $pkgdir/ directory...
==> Starting build()...
Configuring alsa-core-0.5.0.1...
Setup: Encountered missing dependencies:
extensible-exceptions >=0.1.1 && <0.2
==> ERROR: A failure occurred in build().
Aborting...

The package seems to be there in pacman, but missing if I query with cabal

$ pacman -Q | rg extensible-exceptions
haskell-extensible-exceptions 0.1.1.4-17

Returns nothing:

$ cabal list --installed | rg extensible-exceptions

pdc commented on 2017-06-25 16:13

Won't build with latest ghc. I tried replacing 'ghc=8.0.1' with 'ghc' in depends, but makepkg produces errors.