Package Details: haskell-language-server-bin 1.1.0-1

Git Clone URL: https://aur.archlinux.org/haskell-language-server-bin.git (read-only, click to copy)
Package Base: haskell-language-server-bin
Description: Successor of ghcide & haskell-ide-engine. One IDE to rule them all.
Upstream URL: https://github.com/haskell/haskell-language-server
Keywords: haskell
Licenses: Apache
Conflicts: haskell-language-server, haskell-language-server-git
Provides: haskell-language-server
Submitter: berberman
Maintainer: berberman
Last Packager: berberman
Votes: 11
Popularity: 1.07
First Submitted: 2020-07-29 12:38
Last Updated: 2021-04-26 06:41

Latest Comments

1 2 Next › Last »

mrzeznicki commented on 2021-03-29 00:30

I opened an issue https://github.com/haskell/haskell-language-server/issues/1634 in the HLS repository to add this package to README as a way of obtaining HLS on arch. Since they already put the (IMO misguided and wrong, as I explained in the comments) package from community, we have to promote this package as a 1000x better way of getting HLS for the purpose of Haskell development (working for many GHCs, working wrapper etc)

mrzeznicki commented on 2021-01-05 20:17

Starting with 0.8.0, GHC 8.10.3 is supported. PKGBUILD should be modified to include this version in _ghc_versions. Thanks in advance

berberman commented on 2020-10-03 06:31

Enrico1989: No. If you want to remove elements from _ghc_versions, please make sure that you do the same to sha256sums, because elements of those two arrays are mapped one by one orderly.

Enrico1989 commented on 2020-10-01 17:26

You mean adding to it the one line that I get by running this?

sha256sum haskell-language-server-wrapper-Linux.gz

berberman commented on 2020-10-01 12:33

Enrico1989: Use --skipchecksums or edit sha256sums correspondingly.

Enrico1989 commented on 2020-09-27 11:02

I see that PKGBUILD contains

_ghc_versions=('8.6.4' '8.6.5' '8.8.2' '8.8.3' '8.8.4' '8.10.1' '8.10.2')

How can I edit that line to only install the version I need without getting the sha256 error?

berberman commented on 2020-09-04 06:45

@pancho: Thanks! I've ignored the wrapper :)

pancho commented on 2020-09-04 04:28

Ah, the sha256sum of haskell-language-server-wrapper-Linux.gz seems to be now 551b2147cc8f46d7a6a537daba3aa81095d1b81f66e601cb3d8e46c44cabd008.

Cheers!

berberman commented on 2020-09-03 22:53

@samhh: As the error message said, the size of source array and of sha256sums arry should be same, because the elements are corresponding one by one. Please make sure that this corresponding relationship preserves after you editing the source array.

samhh commented on 2020-09-03 22:17

I'm also seeing the failing checksums - possibly because I edited the PKGBUILD to only build a single version? This is the error aura shows me:

Integrity checks (sha256) differ in size from the source array.