Package Details: haskell-libmpd 0.9.0.4-1

Git Clone URL: https://aur.archlinux.org/haskell-libmpd.git (read-only)
Package Base: haskell-libmpd
Description: An MPD client library.
Upstream URL: http://hackage.haskell.org/package/libmpd
Licenses: LGPL
Submitter: None
Maintainer: pdxleif (fosskers)
Last Packager: pdxleif
Votes: 17
Popularity: 0.000188
First Submitted: 2008-06-17 00:53
Last Updated: 2016-01-18 17:09

Dependencies (11)

Required by (1)

Sources (1)

Latest Comments

madalu commented on 2015-09-22 15:45

In fact, several of the dependencies are no longer in aur.

madalu commented on 2015-09-22 15:44

The dependency haskell-attoparsec is no longer in aur.

fosskers commented on 2014-11-20 05:38

Updated to 0.9.0.1

vohof commented on 2014-11-20 00:17

Please update to the latest version.

fosskers commented on 2014-07-10 21:15

Updated to the latest version. Did that help at all?

misc commented on 2014-07-06 18:02

Currently needs a
sed -i "s|0.12|0.13|" libmpd.cabal
before the runhaskell lines to allow attoparsec 0.12.1.

fosskers commented on 2013-12-14 01:09

@pdxleif: Is the build failing because of the missing option?

pdxleif commented on 2013-12-09 03:03

recently makepkg's default options were changed to remove static
libraries from packages. Since ghc-pkg requires static libraries, you
need

options=('staticlibs')

in "haskell-libmpd" PKGBUILD.

If only .so files are needed, adding the option --force to ghc-pkg might
be the right way, but this might lead to problems with other packages

fosskers commented on 2013-01-12 22:23

Taking over maintenance. I contacted the author of libmpd, and he released a new version that fixes the `network` version collision. I'll get this updated soon.

cgirard commented on 2013-01-12 16:50

fosskers will take over.

All comments