Package Details: hawaii-shell 0.8.0-1

Git Clone URL: https://aur.archlinux.org/hawaii-shell.git (read-only)
Package Base: hawaii-shell
Description: Hawaii Shell
Upstream URL: http://hawaiios.org
Licenses: GPL, LGPL
Groups: hawaii
Conflicts: hawaii-shell-git
Submitter: plfiorini
Maintainer: plfiorini (fusion809)
Last Packager: plfiorini
Votes: 6
Popularity: 0.000264
First Submitted: 2015-03-11 07:57
Last Updated: 2016-08-28 10:55

Latest Comments

vorbote commented on 2017-03-06 16:46

Now that Hawaii desktop is called Liri OS (https://liri.io https://github.com/lirios), and all the packages for the latter are in AUR, shouldn't the hawaii desktop PKGBUILDs be droppped entirely?

kaykay91 commented on 2017-01-12 14:59

The package no longer works due to the fact that the hawaii-icon-theme, hawaii-wallpapers and libhawaii are not available.

figue commented on 2016-11-09 15:04

Please, consider to add this patch as a temporary solution for new version file path in greenisland:


build() {
cd build

# Version file path in greenisland changed.
# Commit: https://github.com/hawaii-desktop/hawaii-shell/commit/d02a209082819e3bfa3edd167328b4ed52ebf6e1
sed -e 's#Hawaii/greenisland_version.h#Hawaii/GreenIsland/greenisland_version.h#g' -i ${srcdir}/${pkgname}-${pkgver}/compositor/main.cpp

...
}

plfiorini commented on 2016-08-28 10:56

Updated

goetzc commented on 2016-08-17 02:29

@plfiorini I still get the same error as djringjr.

plfiorini commented on 2016-08-15 07:27

QtWaylandClient cmake config broke with latest Arch updates, I have now excluded the Qt decoration from the build. This means you will be able to build hawaii-shell now, but you will not get nicer decorations for Qt applications.

djringjr commented on 2016-08-10 23:02

I get this error:

Generating moc source materialdecoration.moc
/usr/lib/qt/bin/moc -I/tmp/yaourt-tmp-administrator/aur-hawaii-shell-git/src/build/decorations/material -I/tmp/yaourt-tmp-administrator/aur-hawaii-shell-git/src/hawaii-shell/decorations/material -I/usr/include/qt/QtGui/5.7.0 -I/usr/include/qt/QtGui/5.7.0/QtGui -I/usr/include/qt/QtCore/5.7.0 -I/usr/include/qt/QtCore/5.7.0/QtCore -I/usr/include/qt -I/usr/include/qt/QtCore -I/usr/lib/qt/mkspecs/linux-g++ -I/usr/include/qt/QtGui -I/usr/include/qt/QtWaylandClient -I/usr/include -DQT_CORE_LIB -DQT_GUI_LIB -DQT_NO_DEBUG -DQT_USE_FAST_CONCATENATION -DQT_USE_FAST_OPERATOR_PLUS -DQT_WAYLANDCLIENT_LIB -D_FILE_OFFSET_BITS=64 -D_GNU_SOURCE -D_LARGEFILE64_SOURCE -o /tmp/yaourt-tmp-administrator/aur-hawaii-shell-git/src/build/decorations/material/materialdecoration.moc /tmp/yaourt-tmp-administrator/aur-hawaii-shell-git/src/hawaii-shell/decorations/material/materialdecoration.cpp
/tmp/yaourt-tmp-administrator/aur-hawaii-shell-git/src/hawaii-shell/decorations/material/materialdecoration.cpp:319: Parse error at "IID"
AUTOGEN: error: process for /tmp/yaourt-tmp-administrator/aur-hawaii-shell-git/src/build/decorations/material/materialdecoration.moc failed:
/tmp/yaourt-tmp-administrator/aur-hawaii-shell-git/src/hawaii-shell/decorations/material/materialdecoration.cpp:319: Parse error at "IID"

AUTOGEN: HawaiiMaterialDecoration_automoc.cpp still up to date
moc failed...
make[2]: *** [decorations/material/CMakeFiles/HawaiiMaterialDecoration_automoc.dir/build.make:58: decorations/material/CMakeFiles/HawaiiMaterialDecoration_automoc] Error 1
make[2]: Leaving directory '/tmp/yaourt-tmp-administrator/aur-hawaii-shell-git/src/build'
make[1]: *** [CMakeFiles/Makefile2:1144: decorations/material/CMakeFiles/HawaiiMaterialDecoration_automoc.dir/all] Error 2
make[1]: Leaving directory '/tmp/yaourt-tmp-administrator/aur-hawaii-shell-git/src/build'
make: *** [Makefile:161: all] Error 2
==> ERROR: A failure occurred in build().
Aborting...

plfiorini commented on 2016-06-15 07:18

NM has backwards incompatible changes, the code was updated but the package is still using the old tarball. Will update the package shortly.

Jristz commented on 2016-06-15 02:06

I can install, aparently NetworkManager lack something, the error is in the networkmanager part saying that isWiiFiiMaxHarwareMax or something is not a member of the newtorkmanger during build

EDIT: error is this:


[ 79%] Building CXX object declarative/networkmanager/CMakeFiles/nmplugin.dir/enabledconnections.cpp.o
/home/administrador/Proyectos/aur/otro/hawaii-shell/src/hawaii-desktop-hawaii-shell-5a84205/declarative/networkmanager/enabledconnections.cpp: In constructor 'EnabledConnections::EnabledConnections(QObject*)':
/home/administrador/Proyectos/aur/otro/hawaii-shell/src/hawaii-desktop-hawaii-shell-5a84205/declarative/networkmanager/enabledconnections.cpp:32:22: error: 'isWimaxEnabled' is not a member of 'NetworkManager'
, m_wimaxEnabled(NetworkManager::isWimaxEnabled())
^~~~~~~~~~~~~~
/home/administrador/Proyectos/aur/otro/hawaii-shell/src/hawaii-desktop-hawaii-shell-5a84205/declarative/networkmanager/enabledconnections.cpp:33:24: error: 'isWimaxHardwareEnabled' is not a member of 'NetworkManager'
, m_wimaxHwEnabled(NetworkManager::isWimaxHardwareEnabled())
^~~~~~~~~~~~~~
make[2]: *** [declarative/networkmanager/CMakeFiles/nmplugin.dir/build.make:159: declarative/networkmanager/CMakeFiles/nmplugin.dir/enabledconnections.cpp.o] Error 1
make[1]: *** [CMakeFiles/Makefile2:1001: declarative/networkmanager/CMakeFiles/nmplugin.dir/all] Error 2
make: *** [Makefile:161: all] Error 2
==> ERROR: A failure occurred in build().
Aborting...

fusion809 commented on 2016-01-22 18:03

@plfiorini Well the situation is better... I can build and then install this package now but I can't run it. When I attempted to launch it from SDDM it failed to launch. Other Wayland sessions like GNOME on Wayland is starting fine. Plasma on Wayland could run before I installed hawaii-shell (I can't test it now as this package requires hawaii-qt-wayland which conflicts with qt-wayland -- a dependency of plasma-wayland-session) without issue too.

All comments