Package Details: haxe-git git-1

Git Clone URL: https://aur.archlinux.org/haxe-git.git (read-only, click to copy)
Package Base: haxe-git
Description: An open-source high-level multiplatform programming language and compiler that can produce applications and source code for many different platforms from a single code-base
Upstream URL: https://github.com/HaxeFoundation/haxe
Licenses: GPL2, MIT
Conflicts: haxe
Provides: haxe
Submitter: TopHattedCoder
Maintainer: cthuflu
Last Packager: cthuflu
Votes: 5
Popularity: 0.000000
First Submitted: 2013-09-14 21:42 (UTC)
Last Updated: 2019-01-28 18:56 (UTC)

Required by (8)

Sources (2)

Latest Comments

1 2 Next › Last »

sgalland commented on 2019-04-19 00:30 (UTC)

I was having issues with the latest build. I have to do the following to get everything to build.

Installed opam -- run opam init -- eval opam config env Installed ocaml-sedlex Downgraded to sedlex.1.99.4 (sedlex.regexp missing extension error in v2)

cthuflu commented on 2019-01-28 19:23 (UTC)

Package has been updated to fix errors with copying, LICENSE, and camlp4

daurnimator commented on 2016-02-25 06:48 (UTC)

Fails on: ocamlopt -pp camlp4o -g -I libs/extlib -I libs/extc -I libs/neko -I libs/javalib -I libs/ziplib -I libs/swflib -I libs/xml-light -I libs/ttflib -I libs/ilib -I libs/objsize -c parser.ml sh: camlp4o: command not found File "parser.ml", line 1: Error: Error while running external preprocessor Command line: camlp4o 'parser.ml' > /tmp/ocamlppbbd24b Makefile:170: recipe for target 'parser.cmx' failed make: *** [parser.cmx] Error 2 Looks like you need to add camlp4 to makedepends?

panicbit commented on 2014-09-11 23:17 (UTC)

The haxe binary seems to be symlinked/copied wrongly: $ readlink /bin/haxe /tmp/yaourt-tmp-user/aur-haxe-git/pkg/haxe-git/usr/lib/haxe/haxe

panicbit commented on 2014-09-11 23:12 (UTC)

Building fails due to missing or moved 'LICENSE.txt'.

panicbit commented on 2014-09-11 23:06 (UTC)

Building fails due to missing 'camlp4' make dependency.

dseg commented on 2013-02-25 08:52 (UTC)

@TopHattedCoder Maybe neko 2.0.0 or later required to build the latest svn trunk? I'll update the PKGBUILD as soon as possible when the AUR neko-2.0.0 package is ready.

TopHattedCoder commented on 2013-02-24 16:18 (UTC)

Not working for me, either a haxe issue or a permissions issue: ==> Generating api docs... Uncaught exception - std@module_read

dseg commented on 2012-11-13 17:38 (UTC)

Thanks, it's fixed.