Package Details: hddfancontrol 1.6.2-1

Git Clone URL: https://aur.archlinux.org/hddfancontrol.git (read-only, click to copy)
Package Base: hddfancontrol
Description: Regulate fan speed according to hard drive temperature
Upstream URL: https://github.com/desbma/hddfancontrol
Keywords: drive fan hard hdd temp temperature
Licenses: GPL3
Replaces: python-hddfancontrol
Submitter: desbma
Maintainer: desbma
Last Packager: desbma
Votes: 2
Popularity: 0.000000
First Submitted: 2017-02-25 19:35 (UTC)
Last Updated: 2024-06-16 12:10 (UTC)

Dependencies (6)

Required by (0)

Sources (1)

Latest Comments

pix3l commented on 2022-08-16 15:28 (UTC)

==> Making package: hddfancontrol 1.5.0-2 (wto, 16 sie 2022, 17:22:43)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
  -> Found hddfancontrol-1.5.0.tar.gz
==> Validating source files with sha512sums...
    hddfancontrol-1.5.0.tar.gz ... Passed
==> Extracting sources...
  -> Extracting hddfancontrol-1.5.0.tar.gz with bsdtar
==> Removing existing $pkgdir/ directory...
==> Starting check()...
/usr/lib/python3.10/site-packages/setuptools/installer.py:27: SetuptoolsDeprecationWarning: setuptools.installer is deprecated. Requirements should be satisfied by a PEP 517 installer.
  warnings.warn(
/usr/lib/python3.10/site-packages/pkg_resources/__init__.py:123: PkgResourcesDeprecationWarning: git-archive.dev8b63d73a17 is an invalid version and will not be supported in a future release
  warnings.warn(
/usr/lib/python3.10/site-packages/pkg_resources/__init__.py:123: PkgResourcesDeprecationWarning: 2.10.1.Ludicrous.Lemur is an invalid version and will not be supported in a future release
  warnings.warn(
/usr/lib/python3.10/site-packages/pkg_resources/__init__.py:123: PkgResourcesDeprecationWarning: dev is an invalid version and will not be supported in a future release
  warnings.warn(
Traceback (most recent call last):
  File "/mnt/magazyn/archlinux/hddfancontrol/src/hddfancontrol-1.5.0/setup.py", line 26, in <module>
    setup(
  File "/usr/lib/python3.10/site-packages/setuptools/__init__.py", line 87, in setup
    return distutils.core.setup(**attrs)
  File "/usr/lib/python3.10/site-packages/setuptools/_distutils/core.py", line 135, in setup
    ok = dist.parse_command_line()
  File "/usr/lib/python3.10/site-packages/setuptools/_distutils/dist.py", line 484, in parse_command_line
    args = self._parse_command_opts(parser, args)
  File "/usr/lib/python3.10/site-packages/setuptools/dist.py", line 1104, in _parse_command_opts
    nargs = _Distribution._parse_command_opts(self, parser, args)
  File "/usr/lib/python3.10/site-packages/setuptools/_distutils/dist.py", line 540, in _parse_command_opts
    cmd_class = self.get_command_class(command)
  File "/usr/lib/python3.10/site-packages/setuptools/dist.py", line 951, in get_command_class
    self.cmdclass[command] = cmdclass = ep.load()
  File "/usr/lib/python3.10/importlib/metadata/__init__.py", line 171, in load
    module = import_module(match.group('module'))
  File "/usr/lib/python3.10/importlib/__init__.py", line 126, in import_module
    return _bootstrap._gcd_import(name[level:], package, level)
  File "<frozen importlib._bootstrap>", line 1050, in _gcd_import
  File "<frozen importlib._bootstrap>", line 1027, in _find_and_load
  File "<frozen importlib._bootstrap>", line 1004, in _find_and_load_unlocked
ModuleNotFoundError: No module named 'tasks'

desbma commented on 2018-06-03 22:46 (UTC)

@ManU Fixed, thanks.

ManU commented on 2018-06-03 17:28 (UTC)

python-setuptools is a required dependency to run after installation, otherwise the program won't start (ModuleNotFoundError: No module named 'pkg_resources')