Package Details: hdf-eos5 1.16-2

Git Clone URL: https://aur.archlinux.org/hdf-eos5.git (read-only, click to copy)
Package Base: hdf-eos5
Description: The HDF-EOS5 is a software library designed built on HDF5 to support the same Grid/Point/Swath functionality in HDF-EOS 2 and to the extent possible it will be built with the same calling sequences as the original HDF-EOS 2 library.
Upstream URL: http://www.hdfeos.org/software/library.php
Licenses: GPL
Submitter: XavierCLL
Maintainer: angelv
Last Packager: angelv
Votes: 4
Popularity: 0.000000
First Submitted: 2010-10-18 00:57 (UTC)
Last Updated: 2021-10-10 19:04 (UTC)

Latest Comments

lnicola commented on 2020-03-27 16:15 (UTC)

Source URL needs to be changed to https://observer.gsfc.nasa.gov/ftp/edhs/hdfeos5/latest_release/HDF-EOS5.$pkgver.tar.Z.

Maduvi commented on 2018-09-11 06:40 (UTC)

I am not sure if this is correct, but with recent changes in hdf4, I had to edit this line in PKGBUILD (something similar with hdf-eos2):

- ./configure CC=/usr/bin/h5cc --with-hdf5=/usr --with-zlib=/usr --prefix=/usr \

+ ./configure CC=/opt/hdf4/bin/h4cc --with-hdf5=/usr --with-zlib=/usr --prefix=/usr \

Any reason why CC=/usr/bin/h5cc gives me the following error when configuring?:

checking for h5cc... /usr/bin/h5cc

configure: error: CC is not h5cc

XavierCLL commented on 2016-07-18 23:13 (UTC)

Thanks @richli for your patches and reported it, updated.

richli commented on 2016-07-16 23:02 (UTC)

It looks like this can't build with HDF 1.10. I got it working by using hdf5_18 instead of hdf5. This means the "h5cc" commands must be changed to "h5cc_18". I created an updated PKGBUILD with this, as well as quoting some bash variables and moving the patching to the prepare() function: https://gist.github.com/richli/0f34e5b72494d13394f6c0525a2ff1f2

commented on 2013-06-02 00:03 (UTC)

Please ignore my previous comment. I thought this library includes eos2dump as well.

commented on 2013-06-01 23:36 (UTC)

I just installed it. But I don't know how to run it? Shouldn't the final binary be called "eos2dump"? I cannot find it.

XavierCLL commented on 2013-05-04 21:10 (UTC)

fixed, thanks @denn.

denn commented on 2013-05-04 19:42 (UTC)

Currently package is not building properly. DESTDIR=$startdir/pkg should be replaced with DESTDIR=$pkgdir in PKGBUILD. Also it would be nice to split packaging code into separate package() function to suppress makepkg warning.

fhs commented on 2012-07-20 19:17 (UTC)

configure was failing (see excerpt from config.log below), so I moved the LDFLAGS line below the ./configure line and it worked. ------ configure:3052: checking for C compiler default output file name configure:3079: gcc -march=x86-64 -mtune=generic -O0 -pipe -fstack-protector --param=ssp-buffer-size=4 -D_FORTIFY_SOURCE=2 -lhe5_hdfeos -lGctp -lhdf5_hl -lhdf5 -ljpeg -lz -lsz -lm conftest.c >&5 /usr/bin/ld: cannot find -lhe5_hdfeos /usr/bin/ld: cannot find -lGctp collect2: error: ld returned 1 exit status configure:3082: $? = 1 configure:3120: result: configure: failed program was: | /* confdefs.h. */ | #define PACKAGE_NAME "hdf-eos5" | #define PACKAGE_TARNAME "hdf-eos5" | #define PACKAGE_VERSION "1.8" | #define PACKAGE_STRING "hdf-eos5 1.8" | #define PACKAGE_BUGREPORT "null@bogus.email" | #define PACKAGE "hdf-eos5" | #define VERSION "1.8" | /* end confdefs.h. */ | | int | main () | { | | ; | return 0; | } configure:3127: error: C compiler cannot create executables

XavierCLL commented on 2012-04-05 17:35 (UTC)

mmmm you are right, delete libhdf5 as dependency, thanks @andreas-h

commented on 2012-04-05 15:00 (UTC)

why does this depend on libhdf5? isn't that duplicating the hdf5 dependency?

XavierCLL commented on 2012-02-08 19:45 (UTC)

@smu thanks for report it, updated.

smu commented on 2012-02-08 16:16 (UTC)

does not compile; version 1.14 is no longer available on ftp://edhs1.gsfc.nasa.gov/edhs/hdfeos5/latest_release/ (but 1.14 is).

graziano commented on 2010-11-15 16:20 (UTC)

Can be compiled using hdf5 shared library using h5cc -shlib