Package Details: hdf5-java 1.12.0-3

Git Clone URL: https://aur.archlinux.org/hdf5-java.git (read-only, click to copy)
Package Base: hdf5-java
Description: General purpose library and file format for storing scientific data , w/java bindings
Upstream URL: https://www.hdfgroup.org/hdf5
Licenses: custom
Conflicts: hdf5
Provides: hdf5, hdf5-cpp-fortran
Replaces: hdf5-cpp-fortran
Submitter: greyltc
Maintainer: greyltc
Last Packager: greyltc
Votes: 1
Popularity: 0.000003
First Submitted: 2019-02-03 17:54
Last Updated: 2020-11-20 22:19

Required by (193)

Sources (2)

Pinned Comments

greyltc commented on 2020-11-01 13:56

Tested with jdk11-openjdk installed and set like sudo archlinux-java set java-11-openjdk

Latest Comments

schmui commented on 2020-11-06 09:27

Having troubles installing, with the error:

CMake Error at java/CMakeLists.txt:2 (project):
No CMAKE_Java_COMPILER could be found.

I have followed the pinned suggestion, sudo archlinux-java status shows java-11-opdenjdk as default. Also I have added /usr/bin/java to PATH, as well as exported CMAKE_Java_COMPILER explicitly. Any ideas?

greyltc commented on 2020-11-05 20:34

I don't believe there's anything in the PKGBUILD here that would break java-15-jdk support. I'm also not really sure what javas upstream expects to work here. I've just only tested this working with java-11-openjdk

jester2 commented on 2020-11-05 20:03

Thanks. Are you only supporting java-11-openjdk currently? I believe the newest version that is available is 14

greyltc commented on 2020-11-05 20:00

You're using the wrong java. See my pinned comment

jester2 commented on 2020-11-05 19:58

Hello, I am having issues with the tests running with the java-15-jdk package

check_version -tM                                                    *FAILED*
    Expected exit code (6) differs from actual code (0)
tcheck_version -tm                                                    *FAILED*
    Expected exit code (6) differs from actual code (0)
tcheck_version -tr                                                    *FAILED*
    Expected exit code (6) differs from actual code (0)

Any ideas why this might be happening?

greyltc commented on 2020-11-01 13:56

Tested with jdk11-openjdk installed and set like sudo archlinux-java set java-11-openjdk

Eothred commented on 2020-05-28 07:28

I tested a bit the different options, and found that the issue with cmake/hdf5 seems to be primarily with the combo of fortran and zlib. Turning off fortran and all builds fine, turning off only zlib and it still fails so there is also some other combo which is not quite working.

Maybe for this package it could be an option to not add fortran to simplify. I did not succeed in building this just updating the version number, I also did not succeed building the hdf5 1.12.0 from Arch, so I am wondering if that maintainer has some special setup to make it work.

flying-sheep commented on 2019-12-17 12:53

I get:

Features:
---------
                   Parallel HDF5: no
Parallel Filtered Dataset Writes: no
              Large Parallel I/O: no
              High-level library: yes
                    Threadsafety: no
             Default API mapping: v110
  With deprecated public symbols: yes
          I/O filters (external): deflate(zlib),szip(encoder)
                             MPE: no
                      Direct VFD: no
                         dmalloc: no
  Packages w/ extra debug output: none
                     API tracing: no
            Using memory checker: no
 Memory allocation sanity checks: no
          Function stack tracing: no
       Strict file format checks: no
    Optimization instrumentation: no
Makefile:377: *** missing separator.  Stop.

petronny commented on 2019-10-29 05:54

I'm confused with the name of this package and hdf-java.
What's the difference of these 2 packages?
Could one of these packages use a more distinguishable name?