Package Details: hg-git-hg 631.711baa274f78-1

Git Clone URL: https://aur.archlinux.org/hg-git-hg.git (read-only)
Package Base: hg-git-hg
Description: the Hg-Git mercurial plugin
Upstream URL: http://hg-git.github.com/
Licenses: GPL2
Conflicts: hg-git
Provides: hg-git
Submitter: None
Maintainer: l4r
Last Packager: l4r
Votes: 45
Popularity: 0.000018
First Submitted: 2009-12-03 07:42
Last Updated: 2015-07-19 18:16

Latest Comments

1 2 Next › Last »

markand commented on 2018-11-14 10:39

I think it should be updated because it does not work at the moment:

TypeError: __init__() got an unexpected keyword argument 'createopts'

Rememver: Mercurial has no API compatibility between release, so basically each 6 months this package has to be updated once a new Mercurial version is released.

AlexTalker commented on 2014-06-10 15:08

Please, added depend at python2-dulwich >= 0.9.6, version 0.9.0 uncompatible.

k8n commented on 2014-01-19 21:05

@techlive, done.

techlive commented on 2014-01-01 17:10

@k8n, please add 'provides=(hg-git)' and 'conflicts=(hg-git)'

k8n commented on 2013-11-29 03:37

@techlive

done, thanks for suggestion.

techlive commented on 2013-10-19 19:29

Please depend on [python2-dulwich][1].

[1]: https://aur.archlinux.org/packages/python2-dulwich/

felipec commented on 2012-10-16 05:41

Why not add --optimize=1 to the setup.py options?

hendry commented on 2012-08-06 09:53

I got "abort: No module named repo!" after an upgrade to mercurial 2.3-1 and I found I had to re-install hg-git-hg to make it work again.

jakobm commented on 2011-09-26 11:50

hg bookmark is part of core (see your post install message). Also consider ditching the install script as it is not the place to inform how to use an application.

w0ng commented on 2011-08-24 03:49

please change:
depends=('mercurial' 'python-dulwich-git')
to
depends=('mercurial' 'python-dulwich')

python-dulwich-git is orphaned.