Package Details: hhsuite 3.2.0-1

Git Clone URL: https://aur.archlinux.org/hhsuite.git (read-only, click to copy)
Package Base: hhsuite
Description: A set of programs for protein sequence homology detection by iterative HMM-HMM comparison for computational biology like PSI-BLAST
Upstream URL: https://github.com/soedinglab/hh-suite
Keywords: bioinformatics hh-suite homology search
Licenses: GPL
Submitter: None
Maintainer: semi
Last Packager: semi
Votes: 1
Popularity: 0.000000
First Submitted: 2012-02-28 23:52 (UTC)
Last Updated: 2019-05-19 04:16 (UTC)

Dependencies (0)

Required by (0)

Sources (2)

Latest Comments

althonos commented on 2020-03-12 13:21 (UTC)

@semi : cmake should be listed as a build-dependency, I had to install it manually for the compiling to work.

semi commented on 2019-05-19 04:18 (UTC)

Updated to 3.2.0

erquiroga commented on 2019-05-18 22:27 (UTC)

HH-suite is on v3.2.0 on github https://github.com/soedinglab/hh-suite/archive/v3.2.0.tar.gz

semi commented on 2018-01-07 15:14 (UTC)

Updated to 3.0-beta3

@apolih: If you or someone else wants to provide such packages, I would be happy to reference them in this package.

apolih commented on 2017-05-08 18:13 (UTC) (edited on 2017-05-08 18:20 (UTC) by apolih)

Thanks for providing this package. I have a few suggestions as I have tried to run it: could use optional dependency on a (not yet existing) blast-legacy-bin package with files from ftp://ftp.ncbi.nlm.nih.gov/blast/executables/legacy/2.2.9/ which are needed to run the addss.pl script likewise for a psipred-bin package with files from http://bioinfadmin.cs.ucl.ac.uk/downloads/psipred/ then patch HHPaths.pm to point to directories from those packages

semi commented on 2016-11-01 16:23 (UTC)

Updated to 3.0 beta 2

semi commented on 2016-02-15 12:17 (UTC)

Fixed.

semi commented on 2016-02-15 07:12 (UTC)

I just got a notification that the upstream download link has died. I'm in contact with the upstream authors on where to point the PKGBUILD, please stay tuned until then.

semi commented on 2014-02-27 09:05 (UTC)

Updated package to configure PERLLIB and HHLIB correctly so bundled scripts work out of the box.

semi commented on 2013-03-22 16:14 (UTC)

Updated to 2.0.16

semi commented on 2013-02-04 11:26 (UTC)

Updated to the new version 2.0.15

commented on 2013-02-04 11:26 (UTC)

Disown for adoption.

commented on 2012-12-18 16:03 (UTC)

Hi there, Looks like you're missing a couple of versions, and the source URL has changed. I've included an updated PKGBUILD and a patch that includes unistd.h in hhsearch. PKGBUILD: pkgver=2.0.15 ... source=(use_unistd.patch ftp://toolkit.genzentrum.lmu.de/pub/HH-suite/releases/$pkgname-$pkgver.tar.gz) build() { cd $srcdir/$pkgname-$pkgver/ patch -Np0 -i ../use_unistd.patch make all WITH_NATIVE=1 NO_PNG=1 } ... md5sums=('cab3b8f636c2fda4a459bbe4bee57fc3' 'f995aeceb710715d6ebd4e1fed6df5db') use_unistd.patch: --- src/hhsearch.C 2012-06-15 16:00:13.000000000 +0100 +++ src/hhsearch.C 2012-12-18 15:49:24.726997376 +0000 @@ -44,6 +44,7 @@ #include <errno.h> // perror() #include <cassert> #include <stdexcept> +#include <unistd.h> // access(), R_OK #ifdef PTHREAD #include <pthread.h> // POSIX pthread functions and data structures

commented on 2012-02-28 23:54 (UTC)

Initial upload.