Package Details: hiptext 0.2-1

Git Clone URL: https://aur.archlinux.org/hiptext.git (read-only)
Package Base: hiptext
Description: Command line tool for rendering images and videos inside terminals.
Upstream URL: https://github.com/jart/hiptext
Licenses: GPL
Submitter: alcasa
Maintainer: alcasa
Last Packager: alcasa
Votes: 1
Popularity: 0.000000
First Submitted: 2016-06-18 21:59
Last Updated: 2017-04-06 06:43

Latest Comments

DanMan commented on 2018-12-29 20:28

I fixed the libfreetype-dev required error although I have to run autogen.sh twice which I don't like very much. Either way the fix is here: https://github.com/DanManN/hiptext

Edit: The core cause of the problem in the first place is that freetype-config is no longer packaged with freetype2 and instead pkfconf should be used to find right cflags and ldflags (https://bbs.archlinux.org/viewtopic.php?id=237958).

aksh1618 commented on 2018-12-26 10:22

I get this error trying to install on Arch:

checking for freetype-config... no
configure: error: error: libfreetype-dev is required
==> ERROR: A failure occurred in prepare().
    Aborting...
:: Unable to build hiptext - makepkg exited with code: 4

pzmarzly commented on 2018-12-25 21:39

Doesn't compile on Manjaro. Could you check if it is also the case on Arch? It seems there may be a problem with dependencies or with upstream makefile (I have freetype2 and lib32-freetype2, version 2.9.1-1, installed)

checking for LIBSWSCALE... yes checking for freetype-config... no configure: error: error: libfreetype-dev is required

alcasa commented on 2017-04-06 06:48

@kgizdov Thank you very much for your suggestions. I have updated updated the package with your PKGBUILD, which is arguably a lot better than mine. I will try to keep the guidelines better in mind in the future!

kgizdov commented on 2017-04-06 00:50

@alcasa, there are few issues with this package. You need to look over the Wiki page for Arch packaging standards and correct styling - email, empty variables, binary installation. I took the liberty of making the proper adjustments (https://github.com/kgizdov/hiptext) and also fixing a bug with your 'make install' routine. You should be calling 'make DESTDIR=... install' not 'PREFIX'. Your ffmpeg.patch should be the one from the upstream pull request and have a descriptive name. Also, 'autoconf' and 'configure' work fine if configured correctly - see mentioned repo.

alcasa commented on 2016-10-19 18:41

Thanks for your comment. Changed the dependencies. 0.2 is simply a move to autoconf building. Which in this case doesnt work well with Archlinux. Since no real code has been changed, I would keep the version at 0.1 for the while.

maggicl commented on 2016-10-18 17:02

Version 0.2 has been released: https://github.com/jart/hiptext/releases/tag/0.2
Also, google-glog and gflags are dynamically linked, therefore they should not be only make depends.