Package Details: hledger-git 20160907-1

Git Clone URL: https://aur.archlinux.org/hledger-git.git (read-only)
Package Base: hledger-git
Description: The hledger command-line and web-based accounting tool
Upstream URL: http://hledger.org
Licenses: GPL3
Conflicts: hledger, hledger-ui, hledger-web
Provides: hledger, hledger-ui, hledger-web
Submitter: atweiden
Maintainer: None
Last Packager: xrvdg
Votes: 11
Popularity: 0.009561
First Submitted: 2015-11-17 19:39
Last Updated: 2016-11-07 09:08

Dependencies (3)

Required by (0)

Sources (1)

Latest Comments

fbn commented on 2017-10-06 00:03

The haskell-stack dependency package has been removed, so it's impossible to build this package.
I couldn't compile hledger using stack from the arch repo. But stack-static(AUR) and libtinfo(AUR, to fix -ltinfo issues) works!

xrvdg commented on 2017-01-09 12:19

@NinjaKoala which architecture do you run? Furthermore, could you post your output of `ldd /usr/bin/hledger`. It looks like you had to use ncurses ABI 5 while my installation uses the ncurses provided in the core repository.

NinjaKoala commented on 2017-01-04 16:05

Could you add libtinfo as dependency?
It didn't compile without it for me.

JeffreyA commented on 2017-01-01 18:45

Got a similar error to RunningDroid. The first time I ran makepkg, the ghc stack was installed as a dependency. I suspect the error has something to do with an unconfigured environment after ghc is installed. Not sure if this is something that should be fixed in this package, or in ghc. Blindly ran the command the error suggested and now running makepkg again, seems to be compiling okay.

vlad commented on 2016-11-05 12:37

@mrjn just delete
```
mv stack-ghc8.yaml stack.yaml
```
from PKGBUILD

mrjn commented on 2016-11-03 01:29

Still unable to install hledger-git. Failing with this:


==> Continue building hledger-git ? [Y/n]
==> -------------------------------------
==>
==> Building and installing package
==> Making package: hledger-git 20160907-1 (Thu Nov 3 12:26:39 AEDT 2016)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
-> Cloning hledger git repo...
Cloning into bare repository '/tmp/yaourt-tmp-mrjn/aur-hledger-git/hledger'...
remote: Counting objects: 30511, done.
remote: Compressing objects: 100% (18/18), done.
remote: Total 30511 (delta 7), reused 0 (delta 0), pack-reused 30493
Receiving objects: 100% (30511/30511), 26.33 MiB | 2.49 MiB/s, done.
Resolving deltas: 100% (20554/20554), done.
==> Validating source files with sha256sums...
hledger ... Skipped
==> Extracting sources...
-> Creating working copy of hledger git repo...
Cloning into 'hledger'...
done.
==> Starting pkgver()...
==> Updated version: hledger-git 20161102-1
==> Entering fakeroot environment...
==> Starting package()...
mv: cannot stat 'stack-ghc8.yaml': No such file or directory
==> ERROR: A failure occurred in package().
Aborting...
==> ERROR: Makepkg was unable to build hledger-git.
==> Restart building hledger-git ? [y/N]
==> ------------------------------------

milos commented on 2016-08-04 22:12

The same failure in package() occurs for me:

Compiler version mismatched, found ghc-8.0.1 (x86_64), but expected minor version match with ghc-7.10.3 (x86_64) (based on resolver setting in /tmp/yaourt-tmp-milos/aur-hledger-git/src/hledger/stack.yaml).

RunningDroid commented on 2016-07-21 01:27

Build fails for me:

==> Starting package()...
-> Installing license...
-> Installing...
Compiler version mismatched, found ghc-8.0.1 (x86_64), but expected minor version match with ghc-7.10.3 (x86_64) (based on resolver setting in /home/runningdroid/packages/tmp/hledger-git/src/hledger/stack.yaml).
Try running "stack setup" to install the correct GHC into /home/runningdroid/.stack/programs/x86_64-linux/
==> ERROR: A failure occurred in package().
Aborting...

sasvari commented on 2016-05-02 22:29

also broken here, but with a different error:

Caching build plan
Fetched package index.
Populated index cache.
Running /usr/bin/git reset --hard 24a88489cdca18c14a869c06054d1409cb8b20ba in directory /home/user/.cache/pacaur/hledger-git/src/hledger/.stack-work/downloaded/711c345e233d408f2668201ef05a7e7afd9bfc9a16283ff1d4f0d83b2deb6f4a.tmp/ exited with ExitFailure 128


fatal: Could not parse object '24a88489cdca18c14a869c06054d1409cb8b20ba'.

Please ensure that commit 24a88489cdca18c14a869c06054d1409cb8b20ba exists within https://github.com/simonmichael/wai
==> ERROR: A failure occurred in package().
Aborting...

FlorianJacob commented on 2016-04-30 20:52

The build is currently broken for me:

==> Validating source files with sha256sums...
hledger ... Skipped
==> Extracting sources...
-> Creating working copy of hledger git repo...
Cloning into 'hledger'...
done.
==> Starting pkgver()...
==> Updated version: hledger-git 20160429-1
==> Entering fakeroot environment...
==> Starting package()...
-> Installing license...
-> Installing documentation...
cp: cannot stat 'hledger/hledger.1.md': No such file or directory
==> ERROR: A failure occurred in package().
Aborting...
==> ERROR: Makepkg was unable to build hledger-git.
==> Restart building hledger-git ? [y/N]


Maybe the filename has changed, or am I missing something?

All comments