Package Details: hmcl 3.2.115-1

Git Clone URL: https://aur.archlinux.org/hmcl.git (read-only)
Package Base: hmcl
Description: Hello Minecraft! Launcher, a powerful Minecraft launcher.
Upstream URL: https://github.com/mclauncher/HMCL
Licenses: GPL3
Submitter: hexchain
Maintainer: LinRs
Last Packager: LinRs
Votes: 7
Popularity: 0.180857
First Submitted: 2016-05-04 07:42
Last Updated: 2018-12-04 04:57

Latest Comments

1 2 Next › Last »

yushijinhun commented on 2018-10-20 14:19

The upstream releases very often (several times a week). I think the process of updating the package in AUR can be automated, which can save time and effort. If you need a GitHub webhook, please email me. I'm glad to help.

eschwartz commented on 2018-08-29 23:35

Why is this using unofficial forked prebuilt binaries which severely lag behind upstream releases?

LinRs commented on 2018-06-28 07:36

source file link is broken: 404 not found

Already updated;)

Bram commented on 2018-06-28 04:50

source file link is broken. https://github.com/LinRs/HMCL/releases/download/v3.1.64/HMCL-3.1.64.jar 404 not found

LinRs commented on 2018-06-25 11:14

Already updated:-)

@rocka, thanks for your friendly reminder.

rocka commented on 2018-06-24 13:10

"Version" field in desktop entry file stands for "Version of the Desktop Entry Specification that the desktop entry conforms with", not "Version of Application". Please consider fix this ;)

ref: Desktop Entry Spec. -> Table 2. Standard Keys

Also, HMCL >= 3.0 requires JavaFX provided by Oracle JDK or java-openjfx , which should be added to depends.

LinRs commented on 2018-03-10 14:37

@tastyCheese, hmcl doesn't use convert for any optional features in my condition.

tastyCheese commented on 2018-03-09 17:38

Can you add imagemagick to the make dependencies? Otherwise bash can't find convert command.

LinRs commented on 2018-02-26 14:48

It's recommented to use Java 1.8 or higner as compiler.

@TJM Maybe we can use "java-environment>=8" as dependence.

TJM commented on 2017-07-16 02:22

I am not sure whether is valid to use "java-environment=8" as dependence.
However, only "java-environment" might mislead both aur helpers and noobs, for jdk7 also provides a java environment.