Package Details: holyspirit-svn 2420-5

Git Clone URL: https://aur.archlinux.org/holyspirit-svn.git (read-only)
Package Base: holyspirit-svn
Description: Action role-playing game (ARPG, like diablo)
Upstream URL: http://sourceforge.net/projects/lechemindeladam/
Licenses: GPL
Conflicts: holyspirit
Provides: holyspirit
Submitter: Svenstaro
Maintainer: None
Last Packager: JonnyJD
Votes: 7
Popularity: 0.000000
First Submitted: 2012-06-08 17:39
Last Updated: 2015-10-28 10:49

Latest Comments

« First ‹ Previous 1 2 3 Next › Last »

JonnyJD commented on 2013-03-01 23:17

The PKGBUILD and all patches can also be found here:
https://github.com/JonnyJD/PKGBUILDs/tree/master/holyspirit-svn

JonnyJD commented on 2013-03-01 23:15

Well, I went ahead and patched so it would work with the binary sfml package from "community".
It also needed another patch for qt, not sure why it worked before, but it did.

I only did a quick test, but I can build, install and play fine with current revision (2419 from 2013-02-06).

Have fun.

JonnyJD commented on 2013-02-27 14:05

For reference, this is the bug I reported on sourceforge:
https://sourceforge.net/support/tracker.php?aid=3606206
I also reported on their website. (It doesn't say so, but you DO need an account on their page for that to work)

Maybe I just patch the code before getting an answer, but I don't want to change the dependencies back and forth between sfml and sfml-git.

There will be more errors when upstream expects a different SFML branch than we use.

JonnyJD commented on 2013-02-27 13:26

Thx for the report. SFML API changed a bit since the last 2.0rc and it looks like some of the changes are used by holypirit.
The problem is "some". Other changes seem unexpected so with using sfml-git I get:

/var/abs/local/_src/holyspirit-svn/src/holyspirit-build/Source/Moteurs/moteurGraphique.cpp: In member function 'sf::Vector2f MoteurGraphique::getPositionSouris()':
/var/abs/local/_src/holyspirit-svn/src/holyspirit-build/Source/Moteurs/moteurGraphique.cpp:1054:20: error: 'class sf::RenderWindow' has no member named 'convertCoords'

So I have to ask upstream what version of sgml they actually use. There is a version in the holyspirit source, but that one is also too old for the "BackSpace" thing.

If I don't get a good answer upstream, I am going to patch the code.

Nognir commented on 2013-02-27 10:32

I'm getting errors: http://tinytext.org/WcIr

JonnyJD commented on 2012-07-25 09:18

Thanks Svenstaro. I updated the pkgbuild

Upstream install changes don't work yet. I commented on the ticket in sourceforge. So I basically try to use the features, but work around problems in the PKGBUILD again. This will still stay in /opt for now.
Saving and Logging should work if you add yourself to the games group (and relogin). (all in /opt/share/games/holyspirit, save in Data/User/Saves)

Overall it should work now.

I also added a patch for the configuration crash on exit, see: https://sourceforge.net/tracker/?func=detail&aid=3548046&group_id=212674&atid=1022673

Svenstaro commented on 2012-07-25 02:21

Last time I orphaned the package nobody cared for it. I orphaned it again now. Let's see how it does. Upstream has done some work to address my issues. You guys should get to that.

JonnyJD commented on 2012-07-24 16:37

Please orphan if you don't want to fix it. I would like to make some fixes.

The one to make it build would be:
cmake -DSFML_STATIC_LIBRARIES=FALSE ../..
(../.. instead of ..)

There are also permission problems (you can't save unless you are root) and we obviously don't want to have all these source and object files in the package.

My french is bad though. I don't know if upstream looks into bug reports in english.
For now I only have packaging fixes.

JonnyJD commented on 2012-07-24 16:27

Please orphan if you don't want to fix it. I would like to make some fixes.

The one to make it build would be:
cmake -DSFML_STATIC_LIBRARIES=FALSE ../..
(../.. instead of ..)

There are also permission problems (you can't save unless you are root) and we obviously don't want to have all these source and object files in the package.

My french is bad though. I don't know if upstream looks into bug reports in english.
For now I only have packaging fixes.

Svenstaro commented on 2012-06-16 13:15

Why don't you guys just fix the package?