Package Details: hon 3.9.5-2

Git Clone URL: https://aur.archlinux.org/hon.git (read-only)
Package Base: hon
Description: Heroes of Newerth is a Real Time Strategy game heavily influcenced by DotA
Upstream URL: http://www.heroesofnewerth.com/
Licenses: custom:HoN
Submitter: kaptoxic
Maintainer: kaptoxic
Last Packager: kaptoxic
Votes: 7
Popularity: 0.086022
First Submitted: 2015-09-07 23:14
Last Updated: 2016-08-23 06:19

Latest Comments

kaptoxic commented on 2016-08-24 04:19

After the newest update, strangely, after trying to play a map the game crashed; the console outputted some "cannot find map" errors. I solved it by doing `sudo chmod +r ./*` in /opt/hon/game/maps.

Let me know if anyone gets similar issues---in that case, it would be good perhaps to move the command to the PKGBUILD (or report a bug to the HoN forums).

kaptoxic commented on 2016-08-23 06:22

The version is updated and library conflict should be solved in the PKGBUILD. Sorry for the late response -- not sure why I did not get notifications for previous comments.

@N_mag: the update process should ask to lift privileges; afterwards, the update works just fine
@frank604: update window has to be closed in an awkward way
@frank604: yes, deleting some of those libs suffices (PKGBUILD is updated)

Bitl0rd commented on 2016-08-23 02:34

FIX
SOLVED:
rename o delete in

x64
/opt/hon/libs-x86_64/libstdc++.so.6

x86

/opt/hon/libs-x86/libstdc++.so.6

rename o deleted, work fine!!!

warning: The VAD has been replaced by a hack pending a complete rewrite
libGL error: unable to load driver: i965_dri.so
libGL error: driver pointer missing
libGL error: failed to load driver: i965
libGL error: unable to load driver: i965_dri.so
libGL error: driver pointer missing
libGL error: failed to load driver: i965
libGL error: unable to load driver: swrast_dri.so
libGL error: failed to load driver: swrast
X Error of failed request: BadValue (integer parameter out of range for operation)
Major opcode of failed request: 155 (GLX)
Minor opcode of failed request: 24 (X_GLXCreateNewContext)
Value in failed request: 0x0
Serial number of failed request: 46
Current serial number in output stream: 47.

Bitl0rd commented on 2016-08-22 21:18

please update to 3.9.5

Techman35 commented on 2016-08-22 12:44

Same problem here :(

ln: cannot remove './libs-x86_64/libudev.so.0': Permission denied
warning: The VAD has been replaced by a hack pending a complete rewrite
libGL error: unable to load driver: i965_dri.so
libGL error: driver pointer missing
libGL error: failed to load driver: i965
libGL error: unable to load driver: i965_dri.so
libGL error: driver pointer missing
libGL error: failed to load driver: i965
libGL error: unable to load driver: swrast_dri.so
libGL error: failed to load driver: swrast
X Error of failed request: BadValue (integer parameter out of range for operation)
Major opcode of failed request: 156 (GLX)
Minor opcode of failed request: 24 (X_GLXCreateNewContext)
Value in failed request: 0x0
Serial number of failed request: 46
Current serial number in output stream: 47

frank604 commented on 2016-07-12 04:58

Was getting:
LIBGL_DEBUG=verbose hon

ln: cannot remove './libs-x86_64/libudev.so.0': Permission denied
warning: The VAD has been replaced by a hack pending a complete rewrite
libGL: Can't open configuration file /home/frank604/.drirc: No such file or directory.
libGL: pci id for fd 28: 8086:1916, driver i965
libGL: OpenDriver: trying /usr/lib/xorg/modules/dri/tls/i965_dri.so
libGL: OpenDriver: trying /usr/lib/xorg/modules/dri/i965_dri.so
libGL: dlopen /usr/lib/xorg/modules/dri/i965_dri.so failed (/opt/hon/libs-x86_64/../libs-x86_64/libstdc++.so.6: version `CXXABI_1.3.9' not found (required by /usr/lib/xorg/modules/dri/i965_dri.so))
libGL error: unable to load driver: i965_dri.so
libGL error: driver pointer missing
libGL error: failed to load driver: i965
libGL: pci id for fd 28: 8086:1916, driver i965
libGL: OpenDriver: trying /usr/lib/xorg/modules/dri/tls/i965_dri.so
libGL: OpenDriver: trying /usr/lib/xorg/modules/dri/i965_dri.so
libGL: dlopen /usr/lib/xorg/modules/dri/i965_dri.so failed (/opt/hon/libs-x86_64/../libs-x86_64/libstdc++.so.6: version `CXXABI_1.3.9' not found (required by /usr/lib/xorg/modules/dri/i965_dri.so))
libGL error: unable to load driver: i965_dri.so
libGL error: driver pointer missing
libGL error: failed to load driver: i965
libGL: OpenDriver: trying /usr/lib/xorg/modules/dri/tls/swrast_dri.so
libGL: OpenDriver: trying /usr/lib/xorg/modules/dri/swrast_dri.so
libGL: dlopen /usr/lib/xorg/modules/dri/swrast_dri.so failed (/opt/hon/libs-x86_64/../libs-x86_64/libstdc++.so.6: version `GLIBCXX_3.4.21' not found (required by /usr/lib/xorg/modules/dri/swrast_dri.so))
libGL error: unable to load driver: swrast_dri.so
libGL error: failed to load driver: swrast
X Error of failed request: BadValue (integer parameter out of range for operation)
Major opcode of failed request: 155 (GLX)
Minor opcode of failed request: 24 (X_GLXCreateNewContext)
Value in failed request: 0x0
Serial number of failed request: 46
Current serial number in output stream: 47

Fixed it by renaming libstdc++.so.6 to libstdc++.so.6_ or whatever.
Game now runs however it is outdated. Clicking yes to run the ingame update just closes game.

N_mag commented on 2016-07-10 18:56

I'm getting various permission related problem with the HoN folder being owned by root... It's not with the game itself if I run with sudo, but when the Update tries to run it crashes immediately. Attempted some chown but it still did not help. My user is in games group. Tried running with root user and still wasn't much help... Really strange. I used the *.sh installer from "http://www.heroesofnewerth.com/" and it installed and ran fine without any special permissions.

I saw in the PKGBUILD the chown to root:games and I'm not familiar with this needing to be owned by root... Thanks.

kaptoxic commented on 2015-11-03 00:44

Thanks. I updated the PKGBUILD.

Bitl0rd commented on 2015-10-29 21:52

errors libcgmanager.so.0, libncursesw.so.5 solved find install
add dependencias cgmanager ncurses5-compat-libs

Bitl0rd commented on 2015-10-28 14:57

new download client 3.7.10