Package Details: hoomd-blue v2.2.2.r1.g6e386396a-1

Git Clone URL: https://aur.archlinux.org/hoomd-blue.git (read-only, click to copy)
Package Base: hoomd-blue
Description: A general-purpose particle simulation toolkit using GPUs with CUDA
Upstream URL: http://codeblue.umich.edu/hoomd-blue/index.html
Keywords: Dynamics Molecular
Licenses: custom: University of Michigan "MIT-Like"
Provides: hoomd-blue
Submitter: AsmundEr
Maintainer: AsmundEr
Last Packager: AsmundEr
Votes: 2
Popularity: 0.000000
First Submitted: 2014-10-17 12:45
Last Updated: 2018-04-16 12:05

Latest Comments

1 2 Next › Last »

jpeter commented on 2020-02-28 15:45

Does not build:

==> Starting build()... -- Configuring HOOMD v2.6.0-9-gfc6484e45 -- Updating git submodules -- Could NOT find MPI_C (missing: MPI_C_WORKS) -- Could NOT find MPI_CXX (missing: MPI_CXX_WORKS) CMake Error at /usr/share/cmake-3.16/Modules/FindPackageHandleStandardArgs.cmake:146 (message): Could NOT find MPI (missing: MPI_C_FOUND MPI_CXX_FOUND) Call Stack (most recent call first): /usr/share/cmake-3.16/Modules/FindPackageHandleStandardArgs.cmake:393 (_FPHSA_FAILURE_MESSAGE) /usr/share/cmake-3.16/Modules/FindMPI.cmake:1700 (find_package_handle_standard_args) CMake/hoomd/HOOMDMPISetup.cmake:7 (find_package) CMakeLists.txt:48 (include)

AsmundEr commented on 2019-10-14 20:43

Maybe it should be named hoomd-blue-git. But do note that it builds off the "maint" branch, which corresponds to the latest released version. And I don't know if it is possible to change a package name?

physkets commented on 2019-08-27 13:50

Shouldn't this package be named hoomd-blue-git ?

AsmundEr commented on 2019-08-12 11:25

@phcerdan No good reason for gcc6 at this point; previously it was there due to CUDA not supporting gcc7 some time in the past. Thank you for catching this, I will update the PKGBUILD.

phcerdan commented on 2019-08-12 11:20

Why using gcc6? I installed from source with gcc9 with no problems.

AsmundEr commented on 2017-12-19 08:10

Notice: the latest PKGBUILD now explicitly sets single precision. This used to be the default in older versions.

AsmundEr commented on 2015-11-11 19:41

To person who flagged as out-of-date: it's not actually out of date, this pulls the maint branch from git so it's always up-to-date. Just go ahead and install and you'll get 1.2.1.

I will update the version number in the PKGBUILD (which is old).

AsmundEr commented on 2015-10-30 12:22

HOOMD-blue 1.2.1 fixes CUDA 7.5 compatibility, so CUDA downgrade is no longer necessary.

AsmundEr commented on 2015-10-14 08:01

NOTICE: The latest version of CUDA (7.5) does not work with HOOMD-blue.
Users should downgrade CUDA to 7.0 until this is fixed. If you do not have a copy of 7.0 in /var/cache/pacman/pkg/... you may use this version from the Rollback Machine:
http://ala.seblu.net/packages/c/cuda/cuda-7.0.28-2-x86_64.pkg.tar.xz
See the following thread on the HOOMD-blue mailing list:
https://groups.google.com/forum/#!msg/hoomd-users/T8C0vgk9Bos/R48nVqdPDwAJ

AsmundEr commented on 2015-02-02 11:37

Sorry, that was my fault, upstream URL has changed. Fixed now.