Package Details: hopper4 5.11.4-1

Git Clone URL: https://aur.archlinux.org/hopper4.git (read-only, click to copy)
Package Base: hopper4
Description: Reverse engineering tool that lets you disassemble, decompile and debug your applications
Upstream URL: https://www.hopperapp.com/
Keywords: debug decompile disassemble engineering reverse tool
Licenses: Commercial
Conflicts: hopperv4
Provides: hopperv4
Submitter: jonathon
Maintainer: Mr.Smith1974
Last Packager: Mr.Smith1974
Votes: 29
Popularity: 0.003944
First Submitted: 2021-11-07 18:14 (UTC)
Last Updated: 2023-07-14 08:27 (UTC)

Latest Comments

1 2 Next › Last »

dreieck commented on 2022-07-25 13:32 (UTC)

Can you provide a symlink to the binary to /usr/bin please:

/opt/hopper-v4/bin/Hopper/usr/bin/hopper

Regards!

Viterzgir commented on 2021-11-09 00:32 (UTC) (edited on 2021-11-09 00:32 (UTC) by Viterzgir)

OK, so you're confirming that there is no download source for the full version.

Yes, agree.

jonathon commented on 2021-11-07 18:09 (UTC)

OK, so you're confirming that there is no download source for the full version.

Packaging a demo is of very limited use to people, and relatively pointless given upgrading involves downloading another, separate, package file and installing it - people might as well just download it directly.

Viterzgir commented on 2021-11-07 17:29 (UTC)

@jonathon After installing demo version you can upgrade to full version. Of course you need to have working license.

jonathon commented on 2021-11-06 23:34 (UTC)

@Viterzgir, you've flagged this out of date - have you found a download for the full version of 5.0.0?

jonathon commented on 2021-11-06 19:40 (UTC) (edited on 2021-11-06 19:49 (UTC) by jonathon)

OK... with 5.0.0 downloads appear to be hidden away somewhere due to the change to a one-year license.

This package might need to be split again as 4.9.5 is the last version to work with the older v3/v4 license keys.

bokic commented on 2021-01-23 22:20 (UTC) (edited on 2021-01-23 22:23 (UTC) by bokic)

Seems like we dont need temporary fixup anymore. Should be removed.

# Temporary hacky fix for upstream packaging issue
cd "$pkgdir"/opt/hopper-v4/lib
ln -s /usr/lib/libformw.so.6    libform.so.6
ln -s /usr/lib/libncursesw.so.6 libncurses.so.6
ln -s /usr/lib/libtinfo.so.6    libtinfo.so.6

flacs commented on 2020-01-17 01:23 (UTC)

Currently python2 is a hard dependency; without it Hopper will fail to load. I already contacted the developer and they said they plan to migrate to Python 3 (no time frame mentioned).

jonathon commented on 2020-01-16 23:51 (UTC)

namcap he say:

hopper E: Dependency python2 detected and not included (libraries ['usr/lib/libpython2.7.so.1.0'] needed in files ['opt/hopper-v4/lib/libHopperCore.so'])

So, the question is whether python2 really is needed?

DuBistKomisch commented on 2020-01-16 02:25 (UTC)

any chance this can use python3 now that 2 is EOL, or make python an optional dependency? not sure what it's actually used for