Package Details: houdini-unity-engine 16.5.323-1

Git Clone URL: https://aur.archlinux.org/houdini.git (read-only)
Package Base: houdini
Description: High-end 3D animation package
Upstream URL: https://www.sidefx.com/products/houdini-engine/unity-plug-in/
Licenses: Custom: Side Effects Software
Submitter: mihaim
Maintainer: AWhetter
Last Packager: AWhetter
Votes: 4
Popularity: 0.004514
First Submitted: 2011-10-18 18:03
Last Updated: 2017-12-31 06:28

Dependencies (1)

Required by (0)

Sources (3)

Pinned Comments

AWhetter commented on 2017-11-16 06:00

I've updated this for Houdini 16 but because PySide2 currently doesn't install, I have a hacky setup where I've downloaded and unpacked python2-pyqt5, pyqt5-common, and python2-sip from here (https://archive.archlinux.org/repos/2016/06/15/extra/os/x86_64/). I've then edited /opt/houdini/houdini/python2.7libs/hutil/Qt.py line 318 from "if preferred:" to "if False:" to get houdini to try using PyQt5 instead of just PySide2. Finally I run houdini with `PYTHONPATH=</path/to/unpacked/pyqt/stuff>/usr/lib/python2.7/site-packages/ /opt/houdini/bin/houdini`.

Latest Comments

dreamingincode commented on 2018-04-10 23:51

New build available: 3e2991c66a2f017149efc8f4837b3cb023d2f372 houdini-16.5.405-linux_x86_64_gcc4.8.tar.gz

And hope @prahalad 's patch can be merged :)

And also there's a new libfontconfig incompatibility, and you need to put the libfontconfig.so.1 binary from fontconfig-2.12.6+5+g665584a-1 to /opt/houdini/dsolib/

prahalad commented on 2018-04-08 05:17

why not add this in your package_houdini() section, that should install the dependent pyslide packages.

# Install python
install -d ${pkgdir}/opt/houdini/python
msg2 "Extracting python"
tar xzf pythonlibdeps.tar.gz -C ${pkgdir}/opt/houdini/python
tar xzf python2.7.tar.gz -C ${pkgdir}/opt/houdini/python

HerbertFlunder commented on 2018-01-06 21:48

I had the same problem with the PyQt5 hack. I ended up installing houdini manually using the official install script contained in the tar. Everything is working now. Looking at the script it seems that houdini brings its own python2 and pyside2. Maybe the PKGBUILD should just call the official install script.

ParadoxSpiral commented on 2017-12-14 16:47

Hi, I tried your hack, but when placing a FLIP fluid container, houdini segfaults. Any idea why that might be? Note: I'm using 16.0, not 16.5.

AWhetter commented on 2017-11-16 06:00

I've updated this for Houdini 16 but because PySide2 currently doesn't install, I have a hacky setup where I've downloaded and unpacked python2-pyqt5, pyqt5-common, and python2-sip from here (https://archive.archlinux.org/repos/2016/06/15/extra/os/x86_64/). I've then edited /opt/houdini/houdini/python2.7libs/hutil/Qt.py line 318 from "if preferred:" to "if False:" to get houdini to try using PyQt5 instead of just PySide2. Finally I run houdini with `PYTHONPATH=</path/to/unpacked/pyqt/stuff>/usr/lib/python2.7/site-packages/ /opt/houdini/bin/houdini`.

mills.sean commented on 2017-02-25 23:00

Anyone planning to update this for Houdini 16?

RastaManKing commented on 2016-06-20 11:11

sorry.. gotta download file manually.. should of looked at the pkgbuild :&

RastaManKing commented on 2016-05-29 09:43

i get the following error..

==> Retrieving sources...
==> ERROR: Unknown download protocol: file
Aborting...
==> ERROR: Makepkg was unable to build houdini.

AWhetter commented on 2016-02-21 14:41

Already done!

bda commented on 2016-02-21 13:43

Change the line install=('houdini.install') by install='houdini.install' in PKGBUILD

All comments