Package Details: hplip-minimal 3.20.6-1

Git Clone URL: https://aur.archlinux.org/hplip-minimal.git (read-only, click to copy)
Package Base: hplip-minimal
Description: HPLIP lite build (print and scan drivers only)
Upstream URL: https://developers.hp.com/hp-linux-imaging-and-printing/
Keywords: cups driver hp
Licenses: GPL2, custom
Conflicts: hplip
Provides: hplip
Submitter: None
Maintainer: None
Last Packager: cucullus
Votes: 17
Popularity: 0.000000
First Submitted: 2012-08-19 13:58 (UTC)
Last Updated: 2020-09-11 16:41 (UTC)

Latest Comments

1 2 3 4 5 Next › Last »

zeroconf commented on 2021-07-15 13:32 (UTC) (edited on 2021-07-15 13:40 (UTC) by zeroconf)

Is there any full version of HPLIP in Arch Linux?

Besides, version 3.21.6 is out already - please update! There are already 5 newer versions out since 3.20.6...

https://developers.hp.com/hp-linux-imaging-and-printing/gethplip

https://sourceforge.net/projects/hplip/files/hplip/

There are quite many new models, which support arrived with 3.21 version. Looks like HP is providing a version of HPLIP for Manjaro Linux - does it fit to the Arch as well?

Looks like plugin is already updated - https://aur.archlinux.org/packages/hplip-plugin/

sbalazik commented on 2020-11-12 01:09 (UTC)

checking for sane_open in -lsane... no
configure: error: cannot find sane-backends-devel support (or --disable-scan-build)
==> ERROR: A failure occurred in build().
    Aborting...

Installing sane package helped, so it should probably be added as dependency?

cucullus commented on 2020-09-11 16:43 (UTC)

Adopted and revived

DAC324 commented on 2020-05-05 09:58 (UTC)

hp-toolbox from this package does not work:

  File "/usr/bin/hp-toolbox", line 269, in <module>
    QApplication, ui_package = utils.import_dialog(ui_toolkit)
TypeError: cannot unpack non-iterable NoneType object

ghoti commented on 2019-12-05 00:29 (UTC)

autoreconf seems to exit's with a non zero exit code. I think all you need to do to fix that is just add this command first:

touch NEWS README AUTHORS ChangeLog INSTALL

still trying to get this package working on my machine though.

figue commented on 2019-04-23 19:00 (UTC)

Sorry but I don't use this package anymore. Feel free to adopt.

cucullus commented on 2018-10-15 12:32 (UTC)

Looks like new version doesn't works. Downgrade to 3.18.6 is needed.

figue commented on 2018-01-17 23:39 (UTC)

@cucullus can you check if new version is ok? Thanks!

figue commented on 2017-02-13 21:25 (UTC)

@cucullus done. Thanks!