Package Details: hplip-raw-ledm 3.18.4-1

Git Clone URL: https://aur.archlinux.org/hplip-raw-ledm.git (read-only, click to copy)
Package Base: hplip-raw-ledm
Description: HPLIP with patch for uncompressed scanning on LEDM-based peripherals
Upstream URL: http://hplipopensource.com
Licenses: GPL
Submitter: quartic
Maintainer: None
Last Packager: quartic
Votes: 0
Popularity: 0.000000
First Submitted: 2015-08-15 08:14
Last Updated: 2018-05-12 20:52

Dependencies (20)

Required by (0)

Sources (7)

Latest Comments

dreieck commented on 2020-01-14 14:27

A note to further users:

In the PKGBUILD, in the build()-function, before ./configure, the following needs to be added:

  CFLAGS+=" $(python-config --includes)"
  export CFLAGS

Otherwise an error like

checking for python... /usr/bin/python
checking for python version... 3.8
checking for python platform... linux
checking for python script directory... ${prefix}/lib/python3.8/site-packages
checking for python extension module directory... ${exec_prefix}/lib/python3.8/site-packages
checking for path to Python.h... "using /usr/include/python3.8 ....  python3.8/Python.h"
checking python3.8/Python.h usability... no
checking python3.8/Python.h presence... no
checking for python3.8/Python.h... no
checking python3.8mu/Python.h usability... no
checking python3.8mu/Python.h presence... no
checking for python3.8mu/Python.h... no
checking python3.8m/Python.h usability... no
checking python3.8m/Python.h presence... no
checking for python3.8m/Python.h... no
configure: error: cannot find python-devel support

is likely to come up with python 3.8.

dreieck commented on 2020-01-14 14:26

@quartic:

I maintain my own hplip-3.18, I will not adopt this.

quartic commented on 2019-11-13 20:25

@dreieck I have orphaned the package, as I am not using it anymore. Feel free to adopt it and make changes.

dreieck commented on 2019-11-07 22:20

Can you please add

provides=("hplip=${pkgver}")

and

conflicts=('hplip')

to the PKGBUILD? Because it in fact just does that.

(I am using this package here because it is still version 3.18, hplip 3.19 dropped support for my printer (HP Photosmart B109m, see here for issue))