Package Details: ht 2.1.0-6

Git Clone URL: https://aur.archlinux.org/ht.git (read-only)
Package Base: ht
Description: executable file editor viewer analyzer for MZ, PE and LE. Formerly ht-editor
Upstream URL: https://github.com/sebastianbiallas/ht
Keywords: ht ht-editor hte
Licenses: GPL
Conflicts: ht-editor
Replaces: ht-editor
Submitter: Barthalion
Maintainer: severach (4shadoww)
Last Packager: severach
Votes: 5
Popularity: 0.951034
First Submitted: 2018-01-06 20:55
Last Updated: 2018-03-18 21:05

Latest Comments

severach commented on 2018-03-18 21:06

I took over the package in bulk after all the notifications. All available patches are unreliable. I added a proper patch for abs().

mxfm commented on 2018-02-17 04:12

Can someone takeover the package and make PKGBUILD change specified in the comment below?

wheatdog commented on 2018-02-02 08:19

Add this prepare function to PKGBUILD, then you can build with gcc7.

prepare() {
  cd "$srcdir"/$pkgname-$pkgver
  sed -ie 's/abs(a - b)/abs((int)(a - b))/' htapp.cc
}

cengiz_io commented on 2018-01-29 16:38

Hi!

ht fails to build with gcc 7.

Can you please add following patch to PKGBUILD? (if the license is suitable ofc)

https://www.mail-archive.com/opensuse-commit@opensuse.org/msg112232.html