Package Details: hunspell-en-us-large 2017.08.24-1

Git Clone URL: https://aur.archlinux.org/hunspell-en-us-large.git (read-only)
Package Base: hunspell-en-us-large
Description: US English large hunspell dictionaries
Upstream URL: http://wordlist.sourceforge.net/
Licenses: LGPL, custom:scowl
Submitter: kd35a
Maintainer: kd35a
Last Packager: kd35a
Votes: 13
Popularity: 0.139388
First Submitted: 2014-12-08 11:26
Last Updated: 2017-09-05 18:45

Dependencies (1)

Required by (0)

Sources (1)

Latest Comments

kd35a commented on 2017-12-03 21:23

@petRUShka I see your point, and the best solution in my opinion would be to do as hunspell-en_GB does it: installing as en_GB-large, and then symlinking en_GB to the large dictionary.

But, that would interfere with hunspell-en and hunspell-en_US, which actually uses the same PKGBUILD-file as hunspell-en_GB.

I would also like to add that there is currently a bug opened, with the same issue you are describing, but for hunspell-en_GB. There seems to be a lot of common interest here, and a need for better package structuring.

Delving into this makes me think that the best solution for the Arch community would be for hunspell-en_US to use the large dictionary, just as hunspell-en_GB, and remove my package.

petRUShka commented on 2017-12-03 19:56

I belive it should be installed to /usr/share/hunspell/en_US.dic instead of /usr/share/hunspell/en_US-large.dic.

because:

$ hunspell

Can't open affix or dictionary files for dictionary named "en_US".

$ LANG=en_US-large hunspell

Hunspell 1.6.2