Package Details: hwpviewer 9.20.0.1573-3

Git Clone URL: https://aur.archlinux.org/hwpviewer.git (read-only, click to copy)
Package Base: hwpviewer
Description: An official HWP viewer for Linux by Hancom
Upstream URL: https://www.hancom.com/
Keywords: hwp
Licenses: custom:hwpviewer
Submitter: esjeon
Maintainer: esjeon
Last Packager: esjeon
Votes: 4
Popularity: 0.95
First Submitted: 2020-04-15 00:41
Last Updated: 2021-05-10 16:51

Pinned Comments

esjeon commented on 2021-05-11 02:59

NOTICE
  • For the dependency webkitgtk, I recommend installing webkitgtk-bin. Compiling WebKit simply takes too much time.

  • There is another AUR package, hwpviewer2020, which unofficially redistributes version 11 from Hancom Gooroom OS. Its maintainer has confirmed that Hancom will officially distribute its DEB package, and, once that happens, we will update the packages accordingly.

Latest Comments

1 2 Next › Last »

esjeon commented on 2021-05-11 02:59

NOTICE
  • For the dependency webkitgtk, I recommend installing webkitgtk-bin. Compiling WebKit simply takes too much time.

  • There is another AUR package, hwpviewer2020, which unofficially redistributes version 11 from Hancom Gooroom OS. Its maintainer has confirmed that Hancom will officially distribute its DEB package, and, once that happens, we will update the packages accordingly.

esjeon commented on 2021-05-11 02:39

@DisLogicator Exactly. We don't know how they're gonna name their project. It's gonna be awful if we use a different name or structure.

esjeon commented on 2021-05-11 02:34

Hi, @DisLogicator. I browsed through those packages and the actual offerings from Hancom. I think for now it's wise to keep the current state, because we don't know how they'll structure their project. Once the official package release hit the shelves, we can sort out our packaging strategy.

Jhyub commented on 2021-05-10 03:02

@esjeon Thanks, looks like the package webkitgtk does do something with icu68 (as it has icu68.install) but webkitgtk-bin has a problem. Never tried compiling it, but I think it should be added as an dependency to webkitgtk-bin.

esjeon commented on 2021-05-10 02:17

@Jhyub Found the cause. It's webkitgtk who was loading ICU. This is the result of lddtree $(which hwpviewer):

/usr/bin/hwpviewer (interpreter => /lib64/ld-linux-x86-64.so.2)
    ...
    libwebkitgtk-3.0.so.0 => /usr/lib/libwebkitgtk-3.0.so.0
        ...
        libicui18n.so.68 => /usr/lib/libicui18n.so.68
        libicuuc.so.68 => /usr/lib/libicuuc.so.68
            libicudata.so.68 => /usr/lib/libicudata.so.68
    ...

I updated webkitgtk-bin on my system, and hwpviewer now requires icu68. However, webkitgtk doesn't list icu* packages as its dependency. This sounds like a nasty problem.

For now, I'm just gonna bump the version...

Jhyub commented on 2021-05-10 00:09

This is what I get without icu68.

This is what I get without both of them.

I get an successful run only with icu68

Can't understand why it behaves different, but it seems to depend on icu68 on my device.

esjeon commented on 2021-05-09 08:00

hwpviewer seems to depend on icu68 instead of icu64 now, changed depends (also flagged it out of date because of this)

@Jhyub I did recheck the dependency, but both ldd and actual experiments (i.e. replacing 64 w/ 68) showed it still uses the old libraries. I unflagged the package.

I wonder how you reached the conclusion. I'll be great if you share more info.

Jhyub commented on 2021-04-18 11:14

Hello, I've found this package interesting, and made some improvements for the PKGBUILD.
1. Added "I agree" bypassing by adding header "Referer: https://www.hancom.com/" via DLAGENTS and provided direct .deb download
2. hwpviewer seems to depend on icu68 instead of icu64 now, changed depends (also flagged it out of date because of this)

Please check it out, thank you!
https://gist.github.com/Jhyub/a8f0fd77174ab2b62087c65ede3e7663

esjeon commented on 2020-11-16 12:36

NOTICE
  • You must download the package file (for Ubuntu/64-bit) manually from the official homepage(>>LINK<<), because the company blocked direct access to the file.

  • For webkitgtk, install the binary version (webkitgtk-bin). Compiling webkit takes too long.

OctopusET commented on 2020-11-15 07:03

Thank you for making this package.