Package Details: hy-git 0.15.0.r15.g109c0b0f-2

Git Clone URL: https://aur.archlinux.org/hy-git.git (read-only)
Package Base: hy-git
Description: Python <--> Lisp layer
Upstream URL: http://hylang.org/
Licenses: MIT
Conflicts: hy
Provides: hy
Submitter: zaza
Maintainer: zaza
Last Packager: zaza
Votes: 6
Popularity: 0.000665
First Submitted: 2013-04-11 20:50
Last Updated: 2018-08-05 12:54

Latest Comments

zaza commented on 2018-08-05 12:56

@dluciv

Oh, I've missed it because I've had python-astor-git installed, sorry.

Updated dependency now, although I see python-astor 0.7.1 in testing, so git version wouldn't be needed soon.

dluciv commented on 2018-08-05 12:42

Right now:

The 'astor>=0.7.1' distribution was not found and is required by hy

switching to python-astor-git helps.

zaza commented on 2018-08-05 00:00

@berquist

Thanks. I've updated PKGBUILD.

berquist commented on 2018-08-04 18:10

The latest version now depends on https://aur.archlinux.org/packages/python-funcparserlib/.

zaza commented on 2018-03-04 01:06

@jpcima

Added, thanks.

Sadly current git version doesn't work for me, throwing an error like: ImportError: cannot import name 'HyExpression'. And same git version installed to simple virtualenv works ok. I couldn't easily find solution for this, will check it later.

jpcima commented on 2018-03-02 08:58

Hello, can you please add the conflicts/provides in metadata? thanks

conflicts=('hy')

provides=('hy')

Aperculum commented on 2014-01-23 09:03

Works great now, thanks a lot, zaza

zaza commented on 2014-01-22 22:22

@Aperculum

Thanks. I've uploaded new version with new dependencies.

Aperculum commented on 2014-01-22 21:58

It installs fine but I'm getting

Traceback (most recent call last):
File "/usr/bin/hyc", line 5, in <module>
from pkg_resources import load_entry_point
File "/usr/lib/python3.3/site-packages/pkg_resources.py", line 2697, in <module>
working_set.require(__requires__)
File "/usr/lib/python3.3/site-packages/pkg_resources.py", line 669, in require
needed = self.resolve(parse_requirements(requirements))
File "/usr/lib/python3.3/site-packages/pkg_resources.py", line 572, in resolve
raise DistributionNotFound(req)
pkg_resources.DistributionNotFound: astor>=0.3

When trying to run hy or hyc.