Package Details: hybridreverb2-git r92.6beac8e-3

Git Clone URL: https://aur.archlinux.org/hybridreverb2-git.git (read-only, click to copy)
Package Base: hybridreverb2-git
Description: Hybrid impulse convolution reverb, available as LV2 and VST
Upstream URL: https://github.com/jpcima/HybridReverb2
Licenses: GPL
Conflicts: hybridreverb2
Provides: hybridreverb2
Submitter: jpcima
Maintainer: jpcima
Last Packager: jpcima
Votes: 1
Popularity: 0.024606
First Submitted: 2018-05-27 19:38
Last Updated: 2019-11-26 02:42

Latest Comments

jpcima commented on 2019-11-26 02:52

The commit has added the patch in text mode, which corrupted the CRLF. I fixed it in a new commit.

funkmuscle commented on 2019-11-25 15:05

Still fails to build for me.

patching file modules/juce_graphics/colour/juce_PixelFormats.h Hunk #1 FAILED at 107 (different line endings). Hunk #2 FAILED at 341 (different line endings). Hunk #3 FAILED at 428 (different line endings). Hunk #4 FAILED at 651 (different line endings). 4 out of 4 hunks FAILED -- saving rejects to file modules/juce_graphics/colour/juce_PixelFormats.h.rej patching file modules/juce_graphics/native/juce_RenderingHelpers.h Hunk #1 FAILED at 577 (different line endings). Hunk #2 FAILED at 670 (different line endings). Hunk #3 FAILED at 685 (different line endings). 3 out of 3 hunks FAILED -- saving rejects to file modules/juce_graphics/native/juce_RenderingHelpers.h.rej ==> ERROR: A failure occurred in prepare(). Aborting... :: Unable to build hybridreverb2-git - makepkg exited with code: 4

jpcima commented on 2019-11-24 05:20

It's a bug appeared with GCC9 which affected most JUCE-based software. clang works. I committed a new revision which includes a patch to resolve it.

funkmuscle commented on 2019-11-23 16:17

this fails to build for me:

/tmp/trizen-harv/hybridreverb2-git/src/HybridReverb2/Thirdparty/JUCE/modules/juce_graphics/colour/juce_PixelFormats.h:366:17: note: defined here 366 | class JUCE_API PixelRGB | ^~~~~~~~ make[2]: [CMakeFiles/juce_graphics.dir/build.make:63: CMakeFiles/juce_graphics.dir/JuceLibraryCode/include_juce_graphics.cpp.o] Error 1 make[1]: [CMakeFiles/Makefile2:348: CMakeFiles/juce_graphics.dir/all] Error 2 make: *** [Makefile:130: all] Error 2 ==> ERROR: A failure occurred in build(). Aborting... :: Unable to build hybridreverb2-git - makepkg exited with code: 4

jpcima commented on 2019-02-12 02:01

New version based on a clean chroot build. Sorry, I got acquainted just now with the 'devtools' workflow.

This updates to reflect the most up-to-date software commits. Also, the RIR database was updated with new license text. The original authors have accepted to relicense it from "non-commercial use" to "CC-BY-SA".

sekret commented on 2019-02-11 22:57

Please add git and cmake to makedepends plus jack, libxrandr and libxinerama to depends. Maybe more are missing, but I lost interest...

Please test your packages, best case in a clean chroot, before you upload them here!