Package Details: hyde-git 601.685b288-1

Git Clone URL: https://aur.archlinux.org/hyde-git.git (read-only)
Package Base: hyde-git
Description: Hyde is a static website generator powered by Python & Django.
Upstream URL: https://hyde.github.io/
Licenses: MIT
Conflicts: hyde
Submitter: robertfoster
Maintainer: robertfoster (c-mauderer)
Last Packager: robertfoster
Votes: 7
Popularity: 0.000001
First Submitted: 2010-12-26 19:03
Last Updated: 2018-07-11 11:12

Latest Comments

1 2 Next › Last »

c-mauderer commented on 2018-07-11 18:21

I'll try to have a look at that this weekend if robertfoster isn't faster.

Edit: Just noted: I have written that too late. robertfoster had already updated it when I wrote it.

ChrisMorgan commented on 2018-07-11 02:49

This package needs changes before it can build:

  1. It depends on python2-jinja.
  2. python2-fswrap is at 0.1.2 (which also won’t install without modifications, see my comments on that package), but this package needs 1.0.0 or later. Use python2-fswrap-git, which provides 1.0.1, instead.
  3. python2-commando is at 0.3.4 (which also won’t install without modifications, see my comments on that package), but this package needs 1.0.0 or later. Use python2-commando-git instead.

c-mauderer commented on 2017-06-10 14:43

Hello M0Rf30,

thanks for adding me as co-maintainer. I'll try my best to come up to the expectations.

I still haven't been able to get all tests running again. Therefore I haven't send a patch to the upstream repository yet. But I haven't forgot yet.

Sorry for the long response time. I'm quite busy in the last time.

Kind regards

Christian

robertfoster commented on 2017-05-29 11:20

@c-mauderer now you are a co-maintainer.

c-mauderer commented on 2017-05-14 20:06

It seems that now the versions of MarkupSafe and smartypants that are delivered with arch are higher than the maximum allowed for hyde. You can find here a patch for the arch package that fixes the version in the AUR package:

http://temp.c-mauderer.de/temp/20170514220342-0001-Adapt-module-versions-for-the-ones-provided-with-arc.patch

I'll try to send the patch to the official hyde repo too but I'm not sure whether they will accept it. It seems that the project isn't very active.

Edit: I'll have to get the tests with some updated developer-dependencies running first. So it might need some extra time to get it into the official repo.

c-mauderer commented on 2017-03-05 10:22

It seems that the python-markdown dependency should be a python2-markdown instead.

Beneath that, the current version of hyde has problems with python2-smartypants = 2.0 which is delivered with Arch. I'm not exactly sure where it is used but in my use case it was enough to just tell hyde that it can work with smartypants < 3.0 instead of smartypants < 2.0 in /usr/lib/python2.7/site-packages/hyde-0.8.9-py2.7.egg-info/requires.txt

carstene1ns commented on 2014-01-18 22:36

Just a FYI: I have adopted and updated the hyde[1] package to the latest available version 0.8.8, also the dependencies have been reworked.

[1]: https://aur.archlinux.org/packages/hyde/

max-k commented on 2014-01-07 09:40

Hi.
Could you add these dependencies :
python2-fswrap
python2-typogrify
python2-commando
python2-smartypants

Otherwise, it doesn't work.
Thanks a lot.

veox commented on 2012-01-21 09:55

This should have hyde in 'conflicts', not 'replaces'.

Anonymous comment on 2011-11-09 23:02

Looks like active development has moved to a new site: https://github.com/hyde/hyde

Should this be updated?