Package Details: hyprlang-git 0.5.2.r2.ec6938c-1

Git Clone URL: https://aur.archlinux.org/hyprlang-git.git (read-only, click to copy)
Package Base: hyprlang-git
Description: hyprlang - the hypr configuration language
Upstream URL: https://github.com/hyprwm/hyprlang
Licenses: GPL
Conflicts: hyprlang
Provides: hyprlang, libhyprlang.so
Submitter: jlaunay
Maintainer: zjeffer
Last Packager: zjeffer
Votes: 2
Popularity: 0.29
First Submitted: 2023-12-31 12:36 (UTC)
Last Updated: 2024-06-11 17:43 (UTC)

Required by (20)

Sources (1)

Latest Comments

zjeffer commented on 2024-06-11 16:42 (UTC)

I've opted to adopt the package as the original maintainer disowned it. I've added hyprutils-git to makedepends, should now be fixed.

earlybird commented on 2024-06-11 04:10 (UTC)

'hyprutils' add this package to the makedepends please

alekgr commented on 2024-06-09 15:05 (UTC)

needs hypr-utils please fix

hyprlang-git-0.2.1.r6.d486806-1: parsing pkg list... ==> Making package: hyprlang-git 0.5.2.r2.ec6938c-1 (Sun 09 Jun 2024 10:02:20 AM CDT) ==> Checking runtime dependencies... ==> Checking buildtime dependencies... ==> WARNING: Using existing $srcdir/ tree ==> Starting pkgver()... ==> Removing existing $pkgdir/ directory... ==> Starting build()... Not searching for unused variables given on the command line. -- The C compiler identification is GNU 14.1.1 -- The CXX compiler identification is GNU 14.1.1 -- Detecting C compiler ABI info -- Detecting C compiler ABI info - done -- Check for working C compiler: /usr/bin/cc - skipped -- Detecting C compile features -- Detecting C compile features - done -- Detecting CXX compiler ABI info -- Detecting CXX compiler ABI info - done -- Check for working CXX compiler: /usr/bin/c++ - skipped -- Detecting CXX compile features -- Detecting CXX compile features - done -- Configuring hyprlang in Release -- Found PkgConfig: /usr/bin/pkg-config (found version "2.1.1") -- Checking for module 'hyprutils>=0.1.1' -- Package 'hyprutils', required by 'virtual:world', not found CMake Error at /usr/share/cmake/Modules/FindPkgConfig.cmake:634 (message): The following required packages were not found:

  • hyprutils>=0.1.1

Call Stack (most recent call first): /usr/share/cmake/Modules/FindPkgConfig.cmake:862 (_pkg_check_modules_internal) CMakeLists.txt:32 (pkg_check_modules)

-- Configuring incomplete, errors occurred! ==> ERROR: A failure occurred in build(). Aborting... error: failed to build 'hyprlang-git-0.2.1.r6.d486806-1':

txtsd commented on 2024-03-13 03:21 (UTC)

@se7en Install hyprlang-git separately first, then install hyprcursor or hyprcursor-git.

se7en commented on 2024-03-12 02:38 (UTC)

Hyprcursor requres hyprlang >= 0.4.2 to build hyprland-git

khing0_0 commented on 2024-03-03 03:02 (UTC)

Why flag this as out of date. This is a git package

jlaunay commented on 2024-01-01 15:12 (UTC)

@zjeffer: should build now

zjeffer commented on 2023-12-31 23:49 (UTC)

Build fails:

==> Making package: hyprlang-git 0.1.0.r3.1210de1-1 (Mon 01 Jan 2024 12:48:00 AM CET)
==> Retrieving sources...
  -> Updating hyprlang git repo...
==> Validating source files with sha256sums...
    hyprlang ... Skipped
==> Making package: hyprlang-git 0.1.0.r3.1210de1-1 (Mon 01 Jan 2024 12:48:01 AM CET)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
  -> Updating hyprlang git repo...
==> Validating source files with sha256sums...
    hyprlang ... Skipped
==> Removing existing $srcdir/ directory...
==> Extracting sources...
  -> Creating working copy of hyprlang git repo...
Cloning into 'hyprlang'...
done.
==> Starting pkgver()...
==> Updated version: hyprlang-git 0.1.0.r9.1db2a12-1
==> Sources are ready.
hyprlang-git-0.1.0.r3.1210de1-1: parsing pkg list...
==> Making package: hyprlang-git 0.1.0.r9.1db2a12-1 (Mon 01 Jan 2024 12:48:02 AM CET)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> WARNING: Using existing $srcdir/ tree
==> Starting pkgver()...
==> Removing existing $pkgdir/ directory...
==> Starting build()...
Not searching for unused variables given on the command line.
-- The C compiler identification is GNU 13.2.1
-- The CXX compiler identification is GNU 13.2.1
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Check for working C compiler: /usr/bin/cc - skipped
-- Detecting C compile features
-- Detecting C compile features - done
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Check for working CXX compiler: /usr/bin/c++ - skipped
-- Detecting CXX compile features
-- Detecting CXX compile features - done
-- Configuring done (0.3s)
-- Generating done (0.0s)
-- Build files have been written to: /home/zjeffer/.cache/paru/clone/hyprlang-git/src/build
[ 66%] Building CXX object CMakeFiles/hyprlang.dir/src/config.cpp.o
[ 66%] Building CXX object CMakeFiles/hyprlang.dir/src/common.cpp.o
[100%] Linking CXX shared library libhyprlang.so
[100%] Built target hyprlang
==> Entering fakeroot environment...
==> Starting package()...
-- Install configuration: "Release"
-- Installing: /home/zjeffer/.cache/paru/clone/hyprlang-git/pkg/hyprlang-git/usr/lib/libhyprlang.so
-- Installing: /home/zjeffer/.cache/paru/clone/hyprlang-git/pkg/hyprlang-git/usr/include/hyprlang.hpp
-- Up-to-date: /home/zjeffer/.cache/paru/clone/hyprlang-git/pkg/hyprlang-git/usr/lib/libhyprlang.so
-- Up-to-date: /home/zjeffer/.cache/paru/clone/hyprlang-git/pkg/hyprlang-git/usr/include/hyprlang.hpp
CMake Error at build/cmake_install.cmake:100 (file):
  file INSTALL cannot find
  "/home/zjeffer/.cache/paru/clone/hyprlang-git/src/hyprlang/build/hyprlang.pc":
  No such file or directory.


==> ERROR: A failure occurred in package().
    Aborting...
error: failed to build 'hyprlang-git-0.1.0.r3.1210de1-1': 
error: packages failed to build: hyprlang-git-0.1.0.r3.1210de1-1