Package Details: i2c-piix4-aura-dkms 5.4.6-1

Git Clone URL: https://aur.archlinux.org/i2c-piix4-aura-dkms.git (read-only, click to copy)
Package Base: i2c-piix4-aura-dkms
Description: The i2c-piix4 kernel driver, patched to be used with OpenRGB: https://gitlab.com/CalcProgrammer1/OpenRGB
Upstream URL: https://bugzilla.kernel.org/show_bug.cgi?id=202587
Licenses: GPL2
Submitter: Terence
Maintainer: Terence
Last Packager: Terence
Votes: 2
Popularity: 0.080340
First Submitted: 2019-08-03 00:29
Last Updated: 2019-12-28 20:22

Latest Comments

1 2 Next › Last »

Terence commented on 2020-02-21 20:47

@jambalaya Glad it's working now, all credits to CalcProgrammer1 for the project :)

PS: Sorry for taking so long to respond, didn't notice the message for some reason...

jambalaya commented on 2020-02-03 01:42

Thanks @Terence, you were correct. I had a directory for an older kernel in /usr/lib/modules/ alongside the one for the current kernel. Removing that directory and rebuilding/reinstalling the package ran without any issues. Thanks for a great project!

Terence commented on 2020-02-03 00:56

This package replaces the original i2c-piix4 kernel module so you would modprobe it using the same name and not i2c-piix4-aura.

It looks like there are leftovers from a previous ARCH kernel. I don't think it's related to this package. Try an other DKMS one to see if the same issue exist. If that's the case, maybe try to uninstall and install again DKMS. Otherwise I don't really know.

jambalaya commented on 2020-02-02 21:10

I'm encountering an issue with kernel modules when installing: (3/3) Install DKMS modules ==> dkms install i2c-piix4-aura/5.4.6 -k 5.4.15-arch1-1 ==> Unable to install module i2c-piix4-aura/5.4.6 for kernel 5.3.4-arch1-1-ARCH: Missing kernel modules tree.

Output of uname -a: Linux localhost 5.4.15-arch1-1 #1 SMP PREEMPT Sun, 26 Jan 2020 09:48:50 +0000 x86_64 GNU/Linux

I only have linux and linux-headers installed, installed via pacman with pacman -Syu linux linux-headers. I can also run sudo modprobe i2c-piix4 without any problems, but sudo modprobe i2c-piix4-aura fails as the module isn't found in in directory /lib/modules/5.4.15-arch1-1. I've also verified with pacman -Qi linux that I'm running the most-recently installed kernel (that is, I rebooted at least once since installing the latest kernel).

Am I missing a dependency, or is there an issue with the PKGBUILD?

agm28011997 commented on 2019-12-29 00:22

there is no aur version for openrgb, may be i am not finding it in the right site

Terence commented on 2019-12-28 20:22

Thanks for the heads up @lakin.wecker and @paradon, updated.

paradon commented on 2019-12-23 22:56

URL for the patch needs to be updated to https://gitlab.com/CalcProgrammer1/OpenRGB/uploads/241ead031b210fba3772ea2b648fec05/piix4-2.diff as "OpenAuraSDK" has been renamed to "OpenRGB".

lakin.wecker commented on 2019-12-22 19:01

No longer builds because https://gitlab.com/uploads/CalcProgrammer1/OpenRGB/241ead031b210fba3772ea2b648fec05/piix4-2.diff.diff is no longer a working URL.

Terence commented on 2019-11-11 21:03

@chestm007 Should be fixed once and for all now :)

chestm007 commented on 2019-11-03 01:41

Still getting an error that the checksums dont match with i2c-piix4.c