Package Details: i2c-tools-git r332.4b28579-1

Git Clone URL: https://aur.archlinux.org/i2c-tools-git.git (read-only)
Package Base: i2c-tools-git
Description: Heterogeneous set of I2C tools for Linux that used to be part of lm-sensors.
Upstream URL: https://git.kernel.org/pub/scm/utils/i2c-tools/i2c-tools.git/about/
Licenses: GPL
Conflicts: i2c-tools, i2c-tools-svn
Provides: i2c-tools, i2c-tools-svn
Submitter: dylwhich
Maintainer: dylwhich (cengiz_io)
Last Packager: cengiz_io
Votes: 6
Popularity: 0.025286
First Submitted: 2015-09-21 16:14
Last Updated: 2018-11-18 09:26

Dependencies (4)

  • git (git-git) (make)
  • python-smbus (python-smbus-git) (optional) – python3 bindings
  • python2-smbus (optional) – python2 bindings
  • read-edid (optional) – for decode-edid script

Required by (8)

Sources (1)

Latest Comments

cengiz_io commented on 2018-11-18 09:04

Updated the repo. Tools work fine. Thanks @potatoe

potatoe commented on 2018-11-16 18:36

@cengiz_io: Switching the PKGBUILD's make install command to:

  make DESTDIR="${pkgdir}" PREFIX="/usr" sbindir="/usr/bin" install

worked for me to build and install the package, but I'm not sure if anything actually works post-install (was installing to meet the dependencies for another package, but I'm not actually using any of the I2C-related code paths there).

cengiz_io commented on 2018-11-15 16:07

@potatoe I'll check it asap

potatoe commented on 2018-11-15 00:26

install: cannot create regular file '/usr/local/lib/libi2c.so.0.1.0': Permission denied

Upstream seems to have switched to a Makefile with support for the standard DESTDIR and PREFIX environment variables.

lonaowna commented on 2017-08-31 19:34

Please switch to the new upstream:
https://git.kernel.org/pub/scm/utils/i2c-tools/i2c-tools.git

(info from groeck https://github.com/groeck/lm-sensors/issues/31)

nalgenebottle commented on 2017-05-30 18:14

Package is broken, as the github source is not available any longer ... it seems as if the respective tools are now available in the lm_sensors package ? Not 100% sure ...

dylwhich commented on 2016-01-19 19:54

@thx1138 PKGBUILD has been updated. Thanks!

thx1138 commented on 2016-01-16 03:39

Hmm - it seems this needs to run "make" with "-j1" to avoid "make" getting ahead of itself, with the error:

liblib//libi2c.so: file not libi2c.so: file not recognized: Filelib/libi2c.so: file not recognized: File truncated

So, in the PKGBUILD,

make -j1 EXTRA=eeprog