Package Details: i3lock-lixxia-git r297.a27257f-1

Git Clone URL: https://aur.archlinux.org/i3lock-lixxia-git.git (read-only)
Package Base: i3lock-lixxia-git
Description: An improved screenlocker based upon XCB and PAM (Lixxia fork)
Upstream URL: https://github.com/Lixxia/i3lock
Licenses: MIT
Groups: i3
Conflicts: i3lock
Provides: i3lock
Submitter: arthur33
Maintainer: s3lph
Last Packager: s3lph
Votes: 7
Popularity: 0.000000
First Submitted: 2015-05-22 09:08
Last Updated: 2019-03-02 19:51

Required by (16)

Sources (1)

Latest Comments

lutobler commented on 2019-03-02 18:48

Sorry for not updating this, I transferred the ownership to @s3lph as per his/her request.

s3lph commented on 2019-02-10 17:36

The PKGBUILD is no longer working, as lixxia/i3lock (and upstream i3/i3lock) now uses autoconf instead of a plain Makefile.

If you need a working PKGBUILD, feel free to look at the AUR package for my own fork of lixxia/i3lock: i3lock-s3lph-git/PKGBUILD.

terratronix commented on 2017-04-21 15:18

I have the same problem on my box. I'm using yaourt.
This has been bugging me for quite some time now.

lutobler commented on 2017-03-29 13:38

I think you are right, the PKGBUILD will probably need some fixing. I will look into it in the next couple of days.

EDIT: Sorry it took so long, but it should finally work properly again.

rchowdhury commented on 2017-03-28 21:28

I believe the package version in the AUR details is old, which is causing cower on my system to always think there's a new version to install. It appears that from the git repository, the version should be 0ca5ad-1, rather than 7b59bd-3. It does automatically update the PKGBUILD when I use makepkg, but it's still confusing cower. Is this a problem on my end, or a problem with the package details in the AUR?

EDIT: Thanks for the fix!

lutobler commented on 2016-08-01 15:47

The package should build again now.

lutobler commented on 2016-04-16 16:23

The PKGBUILD fails when applying the 24hour.patch. As the previous commenter said, upstream has added a switch (--24) for this this feature. Please fix the PKGBUILD!

test0 commented on 2016-01-01 13:32

Lixxia has merged a pull request for 24h support.
The patch is no longer necessary, remove it please.

Thanks